Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

[Contribution] oscThumb


Guest
 Share

Recommended Posts

This is not oscThumb error. Probably you do not have put authorizations to 'images' directory. Try set 755 or 707 or 777 for this directory (this depends where shop is).

I'm on Windows server.. Linux permission does not work. Any idea how to set the permission on Windows server?

Link to comment
Share on other sites

  • Replies 443
  • Created
  • Last Reply

Top Posters In This Topic

I'm on Windows server.. Linux permission does not work. Any idea how to set the permission on Windows server?

I got it working.. I just need to set the NTFS folder permission for Internet Guest Account (IUSR_servername) to read and write.

Link to comment
Share on other sites

Hi, I have a problem with the sql file, it comes from this line :

 

INSERT INTO configuration_group (configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible) VALUES (16,'oscThumb','Configuration options for the oscThumb contribution',16,1);

On my phpmyadmin I got:

 

Error

SQL:

INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )
VALUES ( 16, 'oscThumb', 'Configuration options for the oscThumb contribution', 16, 1 );

MySQL answer:Documentation
#1062 - Duplicate entry '16' for key 1

My OScom is new, I never changed anything on tables. Apparently the number 16 of configuration_group table is already used? How can I change that?

 

Thank you in advance.

 

edit: in fact n°16 of configuration_group_id seems to be used by SEO URLs / Options for Ultimate SEO URLs by Chemo

Edited by bobzh
Link to comment
Share on other sites

I have upload 4 images to this product (all 4 images were successfully uploaded) but when I click enlarge I only can see the the 1st images and there is no left or right arrow to view the rest of the images..

 

Any idea?

oscThum does not support this, but you can use a file popup_image.php from my other contributions what named Image Mix.

Link to comment
Share on other sites

Hi, I have a problem with the sql file, it comes from this line :

 

INSERT INTO configuration_group (configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible) VALUES (16,'oscThumb','Configuration options for the oscThumb contribution',16,1);

Fresh installation - I had in mind that nothing is included before.

 

I uploaded the new files, this should be good for everyone. Here is latest 1.1 version of oscThumb.

Link to comment
Share on other sites

I just installed this contrib and unfortunately it's not working. When I enable it there are no thumbnails generated only the alt text for the images. If I click on the image text it goes tot he product page with no thumbnail just text where the image would be. However, if I click the product title under where the image would normally be I get the error below. I didn't receive any sql or other errors during the install. I follow the instructions without issue. I have no problems using the admin interface to change parameters. Any ideas of where the problem is? Thanks in advance for any help.

 

Forbidden

You don't have permission to access /catalog/index.php/cPath/138_143 on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Link to comment
Share on other sites

Any ideas of where the problem is?

Show screenshots instead to describe the problem. It is easier to identify. Someone can help you quickly, when see the error.

For example, errors phpThumb have violet background.

Link to comment
Share on other sites

Show screenshots instead to describe the problem. It is easier to identify. Someone can help you quickly, when see the error.

For example, errors phpThumb have violet background.

 

That's just it...I'm not getting any errors...other than the html error mentioned above and there's nothing there to show. In the product list all I'm getting is the product I'm just not getting thumnails. Perhaps I should mention that I am also displaying products in columns not rows.

Link to comment
Share on other sites

You don't have permission to access /catalog/index.php/cPath/138_143 on this server.

From that, I'd say in your Admin, set 'Use Search-Engine Safe URLs (still in development)' to false.

 

Save it.

 

The URL is screwed. It should be: /catalog/index.php?cPath=138_143

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

From that, I'd say in your Admin, set 'Use Search-Engine Safe URLs (still in development)' to false.

 

Save it.

 

The URL is screwed. It should be: /catalog/index.php?cPath=138_143

 

yes...tried that first and it didn't help. same issue with not receiving thumbnails.

Link to comment
Share on other sites

OscThumb latest version 1.0.1 is available. Here you can see it in action: http://www.novaxim.linuxpl.com/oscDemo/index.php

 

Hi

 

First of all, thanks go to the authors for this contribution - it looks great and well done -

 

however, I've been unable to successfully test it:

 

www.sk8factoryshop.com

 

Many of the thumbnail images come up blank with just the alt text in its place - that's the weird thing, some are fine, others don't show up. A page refresh usually results in a completely different set of images not displaying that were last time!

 

I'm using STS and have implemented all of the suggestions previously made.

 

 

I see there are several people who like me have / or had the same issue, but so far no response from anyone!

 

Can anyone shed any light on this? I'd love to fix it ! :-)

 

 

PS: I should say that I also have On The Fly installed and UltraPics - would that matter?

 

 

 

TIA

Edited by ssnb
Link to comment
Share on other sites

I think I found a bug, thanks to confirm:

 

If you have a big product-information-image (300px for exemple) and have a review on this product, if you see the review on colomn_right when you are on the product page, both images have the same size, so right column is completely too large (300px).

 

Is it clear? :)

Same thing on your site?

 

It's not possible to see this problem on demo page from author ( http://www.novaxim.linuxpl.com/oscDemo/ )

because the product-information-image is too small and no review on the product.

 

Another problem: I think it's not possible to disable Encrypt Image Filenames option. I think the problem above is because of that (same Encrypt for small image in reviews box and product-information-image)

Link to comment
Share on other sites

Same thing on your site?

I had a problem with images in columns (left or right) when width of image exceeded width of the column. However, the problem disappeared. I will check it again.

Box 'What's new?' and 'Revievs' or 'Specials' uses the same display rule, so I think.

You suggesting that I have to set the size of main image (product image) on the 300? I did it.

Please note, that I have now version 1.1 of oscThumb, which exactly installed according to the information in the Install.html file.

 

Encrypt Image Filenames (with thumbnails and watermarks) is a essence feature of this contribution. There is no need to disable Encrypt Image Filenames option. ;)

Link to comment
Share on other sites

Thank you for your quick reply :)

 

I had a problem with images in columns (left or right) when width of image exceeded width of the column. However, the problem disappeared. I will check it again.

Yes, I mean I have this problem.

Did you check?

Just put a large image product, and post a review about it...

 

Box 'What's new?' and 'Revievs' or 'Specials' uses the same display rule, so I think.

You mean it's normal? Reviews box picture and Product picture must have the same width?

 

You suggesting that I have to set the size of main image (product image) on the 300? I did it.

No no, any size must be allowed of course, but I want to keep my 150px right column when I have a Product picture larger...

 

Encrypt Image Filenames (with thumbnails and watermarks) is a essence feature of this contribution. There is no need to disable Encrypt Image Filenames option.

Hehe, I agree with that, but I wanted to test without, if the problem come from that...

Link to comment
Share on other sites

Yes, I mean I have this problem.

Did you check?

Just put a large image product, and post a review about it...

Why do I think that review will change the way?

I wrote that the boxes 'What's new?' and 'Reviews' or 'Specials' uses the same display rule. If you have something bad in the 'Reviews', when it should be same in 'What's new?' and 'Specials', is not it? I noticed problem with large width of product image earlier. Today, I see that I have no problem. Check it out on the oscDemo.

 

You mean it's normal? Reviews box picture and Product picture must have the same width?

Of course, NO!

 

No no, any size must be allowed of course, but I want to keep my 150px right column when I have a Product picture larger...

^ check on my oscDemo.

 

Hehe, I agree with that, but I wanted to test without, if the problem come from that...

You can set the display of original images for other types, such as: logos, buttons, etc. Not checked this, but all images displayed in columns is probably one category. Encrypt Image Filenames option is rather allowed to test a whole.

Link to comment
Share on other sites

Just tried to install this contribution and this is what is happening:

 

 

Parse error: syntax error, unexpected T_VARIABLE in /home/content/y/o/g/yogicchai/html/catalog/yogicchai/includes/application_top.php on line 683

 

// START oscThumb

  require(DIR_WS_CLASSES . 'oscthumb.php');

    $oscthumb = new oscthumb; (This is line 683)

    $oscthumb->check_hash(); // Check if parameters have changed. Delete cache if yes.

// END oscThumb

 

Any suggestions?

Link to comment
Share on other sites

I think I found a bug, thanks to confirm:

 

If you have a big product-information-image (300px for exemple) and have a review on this product, if you see the review on colomn_right when you are on the product page, both images have the same size, so right column is completely too large (300px).

I think, that reason is it, that oscThumb remembers last thumbnails type setting and right-column is after content product_info.php.

Okey, I found two way to solve. First, by adding PRODUCT_INFO_IMAGE_WIDTH and PRODUCT_INFO_IMAGE_HEIGHT for function identify of type or second, by exclusion possibility changing of type for Small Image on product_inf.php page by function identify of type.

For this, lines 40-62 of file 'catalog/includes/classes/oscthumb.php' replace with this:

  function set_type ($src, $width, $height, $thumbnail_type = 0) {
// Try to detect what kind of image we are currently processing, so we can do what have to do with it.
global $product_info;

$this->thumbnail_type = $thumbnail_type;
if ($this->thumbnail_type==0) {  // If thumbnail type is already chosen, do not try to find it again.

  if ( $width == SMALL_IMAGE_WIDTH && $height == SMALL_IMAGE_HEIGHT) {
	$this->thumbnail_type=1;  // Small image
  } elseif ($width == HEADING_IMAGE_WIDTH && $height == HEADING_IMAGE_HEIGHT) {
	$this->thumbnail_type=2;  // Heading image
  } elseif ($width == SUBCATEGORY_IMAGE_WIDTH && $height == SUBCATEGORY_IMAGE_HEIGHT) {
	$this->thumbnail_type=3;  // Subcategory image
  } elseif ($width == PRODUCT_INFO_IMAGE_WIDTH && $height == PRODUCT_INFO_IMAGE_HEIGHT) {
	$this->thumbnail_type=4;  // Product info image
  } elseif (basename ($_SERVER['PHP_SELF'])== FILENAME_PRODUCT_INFO) {
	// Final check just to make sure that we don't interfere with other contribs.
	if (isset($product_info['products_image']) && $src == DIR_WS_IMAGES . $product_info['products_image'] && $product_info['products_id']==(int)$_GET['products_id']) {
	  $this->thumbnail_type=4;  // Product info image
	}
  } elseif (basename ($_SERVER['PHP_SELF'])== FILENAME_POPUP_IMAGE) {
	$this->thumbnail_type=5;  // Popup image
  }
}
 }

and in product_info.php SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, replace with PRODUCT_INFO_IMAGE_WIDTH, PRODUCT_INFO_IMAGE_HEIGHT, or erase it fragment.

 

From this time, all images which have declared PRODUCT_INFO_IMAGE_WIDTH and PRODUCT_INFO_IMAGE_HEIGHT on each page or images without declared dimension on product_info.php will be set thumbnail type for Product Info Image.

 

Committed any errors?

Anyone have a better solution this?

Link to comment
Share on other sites

Is it possible to have oscThumb with Lighbox installed and working correctly?

I think, yes!

I need some time for test it. When I done, then I publish new version of oscThumb, which well work with Lightbox. Please be patient. I have corrected some main errors yet.

Link to comment
Share on other sites

Committed any errors?

Anyone have a better solution this?

I don't know if there is a better solution but seems perfect for me! Thank you so much! :)

 

And for information, I already installed lightbox and it's working well :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...