Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

who can help me about this...please!!


ANRON

Recommended Posts

what's the problem with this messege...?

 

Fatal error: Maximum execution time of 30 seconds exceeded in c:appservwwwcatalogincludesfunctionsdatabase.php on line 19

 

please...is there someone can help with this...

friendly everyone around th world!!

Link to comment
Share on other sites

I can help you a little. There's a line in php.ini that says "max_execution_time = 30". Change it to 60 and see if it takes 60 seconds to get the message. If it does then see what's on line 19 of database.php that might be taking too long.

 

If Windows is the same as Linux, then line 19 says

$$link = mysql_connect($server, $username, $password);

 

So your script is taking longer than 30 seconds to connect to the database. See if you can manually connect to it.

 

This will get you started.

Link to comment
Share on other sites

I can help you a little. There's a line in php.ini that says "max_execution_time = 30". Change it to 60 and see if it takes 60 seconds to get the message. If it does then see what's on line 19 of database.php that might be taking too long.

 

If Windows is the same as Linux, then line 19 says  

$$link = mysql_connect($server, $username, $password);

 

So your script is taking longer than 30 seconds to connect to the database. See if you can manually connect to it.  

 

This will get you started.

 

thank you sir...i'm trying your way..testing now!!anyway thanks very much!!

 

ANRON

friendly everyone around th world!!

Link to comment
Share on other sites

I can help you a little. There's a line in php.ini that says "max_execution_time = 30". Change it to 60 and see if it takes 60 seconds to get the message. If it does then see what's on line 19 of database.php that might be taking too long.

 

If Windows is the same as Linux, then line 19 says  

$$link = mysql_connect($server, $username, $password);

 

So your script is taking longer than 30 seconds to connect to the database. See if you can manually connect to it.  

 

This will get you started.

 

sir...i tried it for couple days..and the problem still on it...what else can i do...thanks!!

friendly everyone around th world!!

Link to comment
Share on other sites

I can help you a little. There's a line in php.ini that says "max_execution_time = 30". Change it to 60 and see if it takes 60 seconds to get the message. If it does then see what's on line 19 of database.php that might be taking too long.

 

If Windows is the same as Linux, then line 19 says  

$$link = mysql_connect($server, $username, $password);

 

So your script is taking longer than 30 seconds to connect to the database. See if you can manually connect to it.  

 

This will get you started.

 

sir...i tried it for couple days..and the problem still on it...what else can i do...thanks!!

 

help me please...my site openning while this problem can fix it...

friendly everyone around th world!!

Link to comment
Share on other sites

My advice wasn't a solution to the problem, just some tests. There was no need to try it for a couple of days. Just one would have been sufficient. I assume setting the timeout to 60 seconds didn't work. Did the error message change to "Fatal error: Maximum execution time of 60 seconds exceeded in...". If that's the case then I assume you tried to connect to the database manually. Did that work? If not then what were the error messages, if any. You need to provide more information.

Link to comment
Share on other sites

My advice wasn't a solution to the problem, just some tests. There was no need to try it for a couple of days. Just one would have been sufficient. I assume setting the timeout to 60 seconds didn't work. Did the error message change to "Fatal error: Maximum execution time of 60 seconds exceeded in...". If that's the case then I assume you tried to connect to the database manually. Did that work? If not then what were the error messages, if any. You need to provide more information.

 

i tried it...mysql is working!!and i had set it to 60 secs..but it still shows

30 secs...is anywhere wrong?it really made me nuts...anyway?

friendly everyone around th world!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...