Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PayPal IPN 096 install


grizzly

Recommended Posts

Hi there,

Just installed paypal ipn 096. I think that I have done everything on the install sheet. When I go to the adnin/modules I get the error at the top of the screen :

 

Warning: Unable to access /usr/local/psa/home/vhosts/comicsnstuff.co.uk/httpdocs/comicstore/catalog/includes/languages/english/modules/payment/paypalipn.php in /usr/local/psa/home/vhosts/comicsnstuff.co.uk/httpdocs/comicstore/admin/modules.php on line 120

 

Warning: Failed opening '/usr/local/psa/home/vhosts/comicsnstuff.co.uk/httpdocs/comicstore/catalog/includes/languages/english/modules/payment/paypalipn.php' for inclusion (include_path='.:') in /usr/local/psa/home/vhosts/comicsnstuff.co.uk/httpdocs/comicstore/admin/modules.php on line 120

 

What is the problem with the install.

 

Also the desription in the modules page in admin says:

 

MODULE_PAYMENT_PAYPALIPN_TEXT_TITLE

 

What should it say.

 

Hope someone can help.

 

Thanks

Link to comment
Share on other sites

Have you figured out your errors yet?

I am getting similar errors after installing IPN 096 for new checkout:

 

 Warning: Failed opening '/home/iceland2/public_html/catalog/includes/languages/english/modules/payment/paypalipn_txn.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/iceland2/public_html/admin/modules.php on line 120



Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/iceland2/public_html/admin/includes/functions/database.php:13) in /home/iceland2/public_html/admin/includes/functions/database.php on line 13

 

as well as BOX_HEADING_PAYPALIPN_ADMIN in the left column.

 

Violet

Link to comment
Share on other sites

Hi Steve,

 

Just wanted to let you know I re-installed the contribution and got rid of the improper link on the left in Admin, but am still getting the other 2 errors. What should be on the left, is "PayPal IPN", and under that will be "Transactions".

 

Let me know if you find out about the other errors, and I will do the same.

 

Violet

Link to comment
Share on other sites

My problem is a little bit different. I am using Ian's October-loaded package and I have installed the Paypal IPN .96-new checkout.

 

It's installed correctly but when I test it to check out (i only have Paypal IPN payment mondule selected) it screws up.

 

1. I goto checkout - /checkout_payment.php - I hit continue it takes me to /checkout_confirmation.php as it should.

 

2. when I hit confirm order it takes me back to /checkout_payment.php

 

what the heck? help!

 

I also noticed in the payment admin area, if you turn off paypal then turn it back on the paypal email address gets reset to [email protected].

Link to comment
Share on other sites

My problem is a little bit different. I am using Ian's October-loaded package and I have installed the Paypal IPN .96-new checkout.

 

Hi Reap

 

It seems you have not readed the NOTE from the Module Description :?

 

NOTE: This version works only with the new checkout code (snapshots since November 1st)

 

Obviously, Ian's October-loaded package is previous to November 1st :wink:

 

You should download the other mod version, or maybe you should wait a little time (maybe hours) until Ian's release his new loaded snapshot that will already have the PayPal IPN v0.96 included!

 

Best regards

Link to comment
Share on other sites

Hi CookieBytes

 

That error you are getting indicated you have a wrong install of the module:

 

Warning: Failed opening '/home/iceland2/public_html/catalog/includes/languages/english/modules/payment/paypalipn_txn.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/iceland2/public_html/admin/modules.php on line 120

 

It is trying to open /catalog/includes/languages/english/modules/payment/paypalipn_txn.php, instead of /catalog/includes/languages/english/modules/payment/paypalipn.php

It seems you copied the paypalipn_txn.php file to /catalog/includes/modules/payment/

 

Please, check your installation and those errors should dissapear!

 

Best regards

Link to comment
Share on other sites

That's it! I had fixed the original error message by moving one file, but I guess I left a file behind when I re-installed the mod.

 

Thanks so much :oops:

 

Violet

Link to comment
Share on other sites

Hey Pablo, Ian said it included the november release but had just the name october on it... ah well, I'll putter around with his new release when he releases it.

 

Thanks bro

 

THANKS GUYS!!! you rock

Link to comment
Share on other sites

Hey Pablo, Ian said it included the november release but had just the name october on it...

 

Ooops... :oops:

 

Anyway, the best is to wait for the new Ian's loaded snapshot!

 

Best regards

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...