Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Prob. with the specials on default.


ulrikhjul

Recommended Posts

Hi...

-I have a problem with specials on default cons. -Ive installed it, and its there...but this error is on top of the screen too.....

 

Warning: Cannot send session cache limiter - headers already sent (output started at /hotel/interlace/WWW/catalog/includes/application_top.php:2) in /hotel/interlace/WWW/catalog/includes/functions/sessions.php on line 67

 

-Can anyone tell me what to do about this??

 

-Also... The tax is not calculated in the specials on default window!?

 

-Anyone?

 

tnx

Link to comment
Share on other sites

.....and when i go to my admin-page under cache-control, this is what i see:

 

Warning: SAFE MODE Restriction in effect. The script whose uid is 6525 is not allowed to access /tmp/ owned by uid 0 in /hotel/interlace/WWW/admin/cache.php on line 82

 

Fatal error: Call to a member function on a non-object in /hotel/interlace/WWW/admin/cache.php on line 83

Link to comment
Share on other sites

...this is to me very weard.........now the error has changed..and i havent done anything...!!!

the error is now;

 

 

Warning: Cannot send session cookie - headers already sent by (output started at /hotel/interlace/WWW/catalog/includes/application_top.php:2) in /hotel/interlace/WWW/catalog/includes/functions/sessions.php on line 67

 

Warning: Cannot send session cache limiter - headers already sent (output started at /hotel/interlace/WWW/catalog/includes/application_top.php:2) in /hotel/interlace/WWW/catalog/includes/functions/sessions.php on line 67

Link to comment
Share on other sites

Turn off the cache "module" in the admin side. Its still under development and is buggy. That's why your getting those errors. Turn OFF the cache feature and your errors about the cache will go away.

Link to comment
Share on other sites

admin/configuration/cache

 

Use Cache: = false

 

I have several guese's as for what the cache control might be used for. But I don't want to say as I might be giving you wrong info. I'm sure someone will chime in tho and explain. . . .

Link to comment
Share on other sites

i think maybe i have more than one prob then.....

...now ive tried to opload my backup-files....so, now my user-side is ok......(just without the specials on default)

-But my admin-page where to change the cache-settings, shows me this error!!!

 

 

Warning: SAFE MODE Restriction in effect. The script whose uid is 6525 is not allowed to access /tmp/ owned by uid 0 in /hotel/interlace/WWW/admin/cache.php on line 82

 

Fatal error: Call to a member function on a non-object in /hotel/interlace/WWW/admin/cache.php on line 83

Link to comment
Share on other sites

  • 3 weeks later...

Had that problem with my provider aswell. Think it has to do with what serversoftware they are using.

 

I asked them to change their PHP settings but it didnt work. And they also said they had the server in safemode or something.

 

A solution is to change the STORE_SESSIONS setting in configure.php to 'mysql'. Worked for me.

 

looks like this:

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

 

Did you find a solution to your specials showing without Tax? I have the same problem and not sure what to do about it. Let me know if you have anything, thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...