Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

images broken after installing SSL


rstn123

Recommended Posts

I changed these

 

define('DIR_WS_IMAGES', 'images/');

 

define('DIR_WS_ICONS', 'icons/');

 

to this

 

define('DIR_WS_IMAGES', 'http://www.myurl.com/catalog/images/');

 

define('DIR_WS_ICONS', 'http://www.myurl.com/catalog/icons/');

 

in configure.php and everything showed up.

Link to comment
Share on other sites

well it did once anyway. now its not showing any of them again. Without the url there is a broken ling but with the url its hitting the images because the sizees are defined it just doesnt show them. I dont know what to do.

Link to comment
Share on other sites

Has anyone come up with a practical fix for this? I've searched and read and nothing has really helped.

 

I'm using a shared secure server and can't actually upload a copy of the missing image files or the checkout scripts to a folder on the server as the way i access is it through a url only.

 

My basic issue is that i'm trying to mod the look and feel of the site but unless the image is one as originally named in a stock install , they aren't showing up in any of the secure areas. The Images that come with oscommerce do. I just can't seem to figure this one out.

 

Any help would be greatly appreciated.

Link to comment
Share on other sites

i cant make any sence of it. you can go to any page on http, then add https instead and everything works perfectly except some of the images. The cart buttons and icons dont show up but the products pic do. This is odd.

Link to comment
Share on other sites

I think I fixed my problem. When adding the ling to an image in my stylesheet i was making the path like so

 

/catalog/images/imagefile.gif

 

I saw in a post somewhere making the path like this

 

../catalog/images/imagefile.gif

 

adding the 2 dots before the forward slash. Fixed me right up :D

Link to comment
Share on other sites

anyone have any ideas for this? I finnaly got my authnet module working so im just down to this last thing keeping me from going live. The path to the images are correct. My certificate covers my entire domain. so http://www.mysite.com/image.jpg should be https://www.mysite.com/image.jpg as well shouldnt it? I am really confused about this. any help would be appreciated.

Link to comment
Share on other sites

Rick...

 

Do you have a URL I could look at? I had the same problem, but found a work-around. It had to do with OSC trying to pull the images from the wrong place...just like Docbob was talking about earlier in this post. My solution was a little different than his, but it seems to work.

 

So let's have a URL.

 

:D

You've tried to philosophize your pain

but the hurt's in your heart and not in your brain

Link to comment
Share on other sites

This is just a guess, but it's worth a look.

 

I notice that you've installed OSC into /catalog/catalog/ instead of just /catalog/. Could this be throwing off your configure.php settings? Does your configure.php say this:

 

define('DIR_WS_IMAGES', 'catalog/images/');

 

Actually, you probably do have it set right...or you wouldn't be getting the images to appear on NONSSL pages either. Hmmmm... Thinking...

 

Just a wild guess, but does your host have a block of some sort that won't allow images to be called via SSL? I don't even know if such a thing exists, but 2 things make me think this might be the case.

 

(1) You're not able to see ANY images through SSL. Your images don't show and neither do the default OSC images. Nothing. Nada.

 

(2) When I call your logo image (http://www.tasteofcajun.com/catalog/catalog/images/taste.gif'>http://www.tasteofcajun.com/catalog/catalog/images/taste.gif) by itself NONSSL, it comes up perfectly fine. When I call it using your SSL syntax (https://) I just get a FORBIDDEN error page. When I do the same test with your main index page (http://www.tasteofcajun.com) the page comes through fine in both NONSSL and SSL.

 

So all of that to say my guess is that it's at the server level...not the OSC program level. Either you're somehow blocked from pulling images through SSL or the (https://) syntax is wrong. Check with your host.

 

Hope this helps in some way. Good luck! :D

You've tried to philosophize your pain

but the hurt's in your heart and not in your brain

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...