Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

specials not working in admin - sql error syntax


gilurv

Recommended Posts

Hello,

 

when i am in my admin area and click on catalog/specials i get this following error message and as i am quite useless with sql....

 

*******************

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.products_id, pd.products_name, p.products_price, s.specials_id, s.specials_new_products_price, s.specials_date_added, s.specials_last_modified, s.expires_date, s.date_status_change, s.status from products p, specials s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -20, 20

 

[TEP STOP]

************************

 

Any idea what that is? and how i could correct that? i have added a few contributions, the only one that changes something in sql was the "more pics" one.

 

Thank you in advance for any potential solutions.

Link to comment
Share on other sites

Hello,

 

when i am in my admin area and click on catalog/specials i get this following error message and as i am quite useless with sql....

 

*******************

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select p.products_id, pd.products_name, p.products_price, s.specials_id, s.specials_new_products_price, s.specials_date_added, s.specials_last_modified, s.expires_date, s.date_status_change, s.status from products p, specials s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -20, 20

 

[TEP STOP]

************************

 

Any idea what that is? and how i could correct that? i have added a few contributions, the only one that changes something in sql was the "more pics" one.

 

Thank you in advance for any potential solutions.

 

All ok now.....

I found my answered there : http://www.oscommerce.com/forums/index.php?showtopic=144095 for those that are having the same problem.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...