Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Lack of Support


Opesman1

Recommended Posts

These problems are about to push me over the edge!! I have followed the osCommerce installation instructions to a T and for some reason things are not working. I have even reloaded the files countless times just to make sure that I didn't mess anything up. You know, I would be laughing right now if I found the solution to these problems but to no avail the answer eludes me and apparently everybody else to because I have yet to find any viable solutions in this forum. So, I have thought this through and the problems are as follows:

 

#1 I'm having problems getting my hosting service to give me any answers, they just keep telling me that they don't support osCommerce, but they have Techs and customers that use this software (because they have told me so) but they are unwilling to help me. Also I have been unsuccessful at contacting the individual that sold me the script for my store! Go figure! This online thing is starting to leave a bad taste in my mouth form all the BS out there!!!!!!!!

 

#2 Either the problem I have is non-existent or nobody on this forum has ever experienced this problem before.

 

#3 My coding experience wouldn't amount to a hill beans!

 

#4 Okay, I'm blowing off a little steam, I've been at this for over a week with no help! And again I don't know PHP!!

 

#5 "The Actual Problem(s)":

 

A) I have not been able to get my path structure correct because I don't know what the damn script is asking for!

 

B) Of course if I don't get that right,then the whole thing is a waste of time! And not to mention the errors that this is causing!

 

C) I have been all over the web this last week and I don't have any idea what all the parameters mean or what info there are asking for. The parameters are not part of PHP, they are not part of Apache, as far as I can tell, they are not part of anything, but they have to be commands or designators or parameters for something and therefore have to have some sort of configuration structure as well as documentation. Here are the files in question, and I believe if I'm having these problems, then someone else is also having these problems.

 

 

####### includes/configure.php #######

 

<?php

define('HTTP_SERVER', 'http://www.blrebookemporium.com');

define('HTTPS_SERVER', 'http://www.blrebookemporium.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'www.blrebookemporium.com');

define('HTTPS_COOKIE_DOMAIN', 'www.blrebookemporium.com');

define('HTTP_COOKIE_PATH', 'catalog/');

define('HTTPS_COOKIE_PATH', 'catalog/');

define('DIR_WS_HTTP_CATALOG', 'catalog/');

define('DIR_WS_HTTPS_CATALOG', 'catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/var/www/html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'XXXXXXXX');

define('DB_SERVER_PASSWORD', 'XXXXXXXX');

define('DB_DATABASE', 'XXXXXXXXXXXXXXX');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

####### admin/includes/configure.php #######

 

<?php

define('HTTP_SERVER', 'http://www.blrebookemporium.com');

define('HTTP_CATALOG_SERVER', 'http://www.blrebookemporium.com');

define('HTTPS_CATALOG_SERVER', 'http://www.blrebookemporium.com');

define('ENABLE_SSL_CATALOG', 'false');

define('DIR_FS_DOCUMENT_ROOT', '/var/www/html/');

define('DIR_WS_ADMIN', 'admin/');

define('DIR_FS_ADMIN', '/var/www/html/catalog/admin/');

define('DIR_WS_CATALOG', 'catalog/');

define('DIR_FS_CATALOG', '/var/www/html/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '********');

define('DB_SERVER_PASSWORD', '********');

define('DB_DATABASE', '****************');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

The info that I do have is this: I am not on a shared server I'm on a dedicated server.

I will not get any support from my hosting service because they do not support osCommerce.

My DOCUMENT_ROOT is "/var/www/html" but I don't know why osCommerce admin says it is "/var/www/html/catalog"

osCommerce says that the URL for my site is "www.mydomain.com/catalog and I want the URL www.mydomain.com to be where people go to see my site.

 

Please! Could someone tell me what I'm doing wrong? And please explain in detail. If I have left out any information that will help with a solution please feel free to email me so that I can obtain that info for you. I will understand what I'm doing much better with a detailed explanation, or at least tell me where I can find the information that will make this mud as clear as glass! :blink:

 

Thank You,

 

William Reynolds/CEO

www.fishingwithbugs.com Hand Tied flies, Gold Fishing Lures & Fly Fishing Gear!

Link to comment
Share on other sites

These problems are about to push me over the edge!! I have followed the osCommerce installation instructions to a T and for some reason things are not working. I have even reloaded the files countless times just to make sure that I didn't mess anything up. You know, I would be laughing right now if I found the solution to these problems but to no avail the answer eludes me and apparently everybody else to because I have yet to find any viable solutions in this forum. So, I have thought this through and the problems are as follows:

 

#1 I'm having problems getting my hosting service to give me any answers, they just keep telling me that they don't support osCommerce, but they have Techs and customers that use this software (because they have told me so) but they are unwilling to help me. Also I have been unsuccessful at contacting the individual that sold me the script for my store! Go figure! This online thing is starting to leave a bad taste in my mouth form all the BS out there!!!!!!!!

 

#2 Either the problem I have is non-existent or nobody on this forum has ever experienced this problem before.

 

#3 My coding experience wouldn't amount to a hill beans!

 

#4 Okay, I'm blowing off a little steam, I've been at this for over a week with no help! And again I don't know PHP!!

 

#5 "The Actual Problem(s)":

 

A) I have not been able to get my path structure correct because I don't know what the damn script is asking for!

 

B) Of course if I don't get that right,then the whole thing is a waste of time! And not to mention the errors that this is causing!

 

C) I have been all over the web this last week and I don't have any idea what all the parameters mean or what info there are asking for. The parameters are not part of PHP, they are not part of Apache, as far as I can tell, they are not part of anything, but they have to be commands or designators or parameters for something and therefore have to have some sort of configuration structure as well as documentation. Here are the files in question, and I believe if I'm having these problems, then someone else is also having these problems.

####### includes/configure.php #######

 

<?php

define('HTTP_SERVER', 'http://www.blrebookemporium.com');

define('HTTPS_SERVER', 'http://www.blrebookemporium.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'www.blrebookemporium.com');

define('HTTPS_COOKIE_DOMAIN', 'www.blrebookemporium.com');

define('HTTP_COOKIE_PATH', 'catalog/');

define('HTTPS_COOKIE_PATH', 'catalog/');

define('DIR_WS_HTTP_CATALOG', 'catalog/');

define('DIR_WS_HTTPS_CATALOG', 'catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/var/www/html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'XXXXXXXX');

define('DB_SERVER_PASSWORD', 'XXXXXXXX');

define('DB_DATABASE', 'XXXXXXXXXXXXXXX');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

####### admin/includes/configure.php #######

 

<?php

define('HTTP_SERVER', 'http://www.blrebookemporium.com');

define('HTTP_CATALOG_SERVER', 'http://www.blrebookemporium.com');

define('HTTPS_CATALOG_SERVER', 'http://www.blrebookemporium.com');

define('ENABLE_SSL_CATALOG', 'false');

define('DIR_FS_DOCUMENT_ROOT', '/var/www/html/');

define('DIR_WS_ADMIN', 'admin/');

define('DIR_FS_ADMIN', '/var/www/html/catalog/admin/');

define('DIR_WS_CATALOG', 'catalog/');

define('DIR_FS_CATALOG', '/var/www/html/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '********');

define('DB_SERVER_PASSWORD', '********');

define('DB_DATABASE', '****************');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

The info that I do have is this: I am not on a shared server I'm on a dedicated server.

I will not get any support from my hosting service because they do not support osCommerce.

My DOCUMENT_ROOT is "/var/www/html" but I don't know why osCommerce admin says it is "/var/www/html/catalog"

osCommerce says that the URL for my site is "www.mydomain.com/catalog and I want the URL www.mydomain.com to be where people go to see my site.

 

Please! Could someone tell me what I'm doing wrong? And please explain in detail. If I have left out any information that will help with a solution please feel free to email me so that I can obtain that info for you. I will understand what I'm doing much better with a detailed explanation, or at least tell me where I can find the information that will make this mud as clear as glass! :blink:

 

Thank You,

 

William Reynolds/CEO

www.fishingwithbugs.com Hand Tied flies, Gold Fishing Lures & Fly Fishing Gear!

 

OK, piece by piece . . .

 

The path thing can be confusing. There are effectively two machines running here; 1. The actual physical computer that your website runs on, and 2. The webserver within that machine.

 

The /var/www/html path is one on the actual computer (it's a normal Unix/Linux path). You should for the time being ignore that, it shouldn't be referenced at all when you're setting up OScommerce.

 

When you access your site from the web, the webserver will point you to the contents of the html directory. that's the 'root' of the site, so any attempt to access a page further down that tree will fail.

 

So, I'd suggest to start with you alter the paths to remove ANY reference to any part of the /var/www/html path. So for example change 'define('DIR_FS_CATALOG', '/var/www/html/catalog/');' to 'define('DIR_FS_CATALOG', 'catalog/');

 

Try that and let us know what happens - we'll get this solved.

 

;)

Link to comment
Share on other sites

To help in zeroing in on the issue you are having, what script did you purchase that requires osCommerce to be installed.

Installed Contributions: CCGV, Close Popup, Dynamic Meta Tags, Easy Populate, Froogle Data Feeder, Google Position, Infobox Header Entire Row, Live Support for OSC, PayPal Seal with CC images, Report_m Sales, Shop by Price Revised, SQL Updater, Who's Online Enhancement, Footer, GNA EP Assistant and still going.

Link to comment
Share on other sites

These problems are about to push me over the edge!! I have followed the osCommerce installation instructions to a T and for some reason things are not working. I have even reloaded the files countless times just to make sure that I didn't mess anything up. You know, I would be laughing right now if I found the solution to these problems but to no avail the answer eludes me and apparently everybody else to because I have yet to find any viable solutions in this forum. So, I have thought this through and the problems are as follows:

 

#1 I'm having problems getting my hosting service to give me any answers, they just keep telling me that they don't support osCommerce, but they have Techs and customers that use this software (because they have told me so) but they are unwilling to help me. Also I have been unsuccessful at contacting the individual that sold me the script for my store! Go figure! This online thing is starting to leave a bad taste in my mouth form all the BS out there!!!!!!!!

 

 

<?php

define('HTTP_COOKIE_PATH', 'catalog/');

define('HTTPS_COOKIE_PATH', 'catalog/');

define('DIR_WS_HTTP_CATALOG', 'catalog/');

define('DIR_WS_HTTPS_CATALOG', 'catalog/');

For number 1, you've got a bad hosting company (as far as oscommerce is concerened). But many are like that. You either need to accept it, in which case this will happen the next time you have a problem with your shop, or change hosts.

 

For the shops confiugre file, change the above entries by removing catalog from each line (leave the apostrophes though.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

For number 1, you've got a bad hosting company (as far as oscommerce is concerened). But many are like that. You either need to accept it, in which case this will happen the next time you have a problem with your shop, or change hosts.

 

For the shops confiugre file, change the above entries by removing catalog from each line (leave the apostrophes though.

 

Jack

 

 

want a hosting company that uses cPanel: it has a auto install for this free software, and will install it automatically.

 

That will resolve the getting working bit, you just need to configure it and be willing to learn PHP on the way.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...