Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Install Stuck


SnowWolf

Recommended Posts

I am using 2.2 rc1 and my host is GoDaddy.com.

 

I made a MySQL DB using MySQL 5.0 and the first step on the install is stuck at:

 

"The database structure is now being imported. Please be patient during this procedure."

 

I tried using a 4.1 DB and it got past the first step but with many errors:

 

Warning: mysql_select_db(): Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 29

Warning: mysql_select_db(): A link to the server could not be established in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 29

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 39

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Link to comment
Share on other sites

I am using 2.2 rc1 and my host is GoDaddy.com.

 

I made a MySQL DB using MySQL 5.0 and the first step on the install is stuck at:

 

"The database structure is now being imported. Please be patient during this procedure."

 

I tried using a 4.1 DB and it got past the first step but with many errors:

 

Warning: mysql_select_db(): Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 29

Warning: mysql_select_db(): A link to the server could not be established in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 29

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 39

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/content/t/h/e/thewhitewillow/html/install/includes/functions/database.php on line 35

Link to comment
Share on other sites

I fixed it, oddly enough I accessed the site through a proxy and it worked just fine.

 

I'm having the same problem on godaddy.

 

How do you "access through a proxy"???

Installed Modules:

Dynamenu, InfoBox Admin, Master Products v.1.2, Header Tags Controller, Multiple Products Manager, Quick Edit in Admin, Secure Admin, Ultimate SEO URL's, EZ Secure Order, Easy Populate v.2.76d MS2, AuthorizeNet_AIM, ChangeFinal Breadcrumb Title, FedEx Labels, Fedex Direct 2.06, How Did you Hear 1.5, Login a la Amazon, UPS XML 1.2.4, USPS Labels, USPS Methods API MS2

Link to comment
Share on other sites

I am also having this problem. Could someone post an explaination and a workaround?

 

I had created my mysql database as v5.0 when I got the problem so I went back, deleted that DB and created a new one as a v.4.1 mysql db which worked. Don't know why but still, there you have it.

Installed Modules:

Dynamenu, InfoBox Admin, Master Products v.1.2, Header Tags Controller, Multiple Products Manager, Quick Edit in Admin, Secure Admin, Ultimate SEO URL's, EZ Secure Order, Easy Populate v.2.76d MS2, AuthorizeNet_AIM, ChangeFinal Breadcrumb Title, FedEx Labels, Fedex Direct 2.06, How Did you Hear 1.5, Login a la Amazon, UPS XML 1.2.4, USPS Labels, USPS Methods API MS2

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...