Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
quicklyshop

Ebay auction manager for OSCOMMERCE

Recommended Posts

Guest
I am getting reports that this error comes up when people first try to hit my site.  If you hit refresh it goes away.  I believe it has something to do with getting a new session id.  Anyone help me out?

 

Fatal error: Cannot instantiate non-existent class: auctioncart in /var/www/html/osc/catalog/includes/application_top.php on line 273

 

 ?//+++AUCTIONBLOX.COM
?if (tep_session_is_registered('auctionCart') && is_object($auctionCart)) {
? ?if (PHP_VERSION < 4) {
? ? ?$broken_cart = $cart;
? ? ?$auctionCart = new auctionCart;
? ? ?$auctionCart->unserialize($broken_cart);
? ?}
?} else {
? ?tep_session_register('auctionCart');
? ?$auctionCart = new auctionCart; ? <-- Line 273
?}
?//+++AUCTIONBLOX.COM

 

That's the bit of code that is doing it.

I am not familiar with your mods, but can see you have used the shopping cart as a basis - do you have a class file like catalog/includes/classes/shopping_cart.php..? - you also will need a call to it in application_top.php - eg.

 

 ?require(DIR_WS_CLASSES . 'auction_cart.php');

 

HTH

 

Matti

Edited by Johnson

Share this post


Link to post
Share on other sites
Guest

Matti, thanks for the reply.

 

auction_cart.php is located in /catalog/includes/classes/

 

I added the below line to /catalog/includes/application_top.php

require(DIR_WS_CLASSES . 'auction_cart.php');

 

And it gives me the following error:

Warning: main(DIR_WS_CLASSESauction_cart.php): failed to open stream: No such file or directory in /var/www/html/osc/catalog/includes/application_top.php on line 13

Fatal error: main(): Failed opening required 'DIR_WS_CLASSESauction_cart.php' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/osc/catalog/includes/application_top.php on line 13

 

Any other ideas?

Share this post


Link to post
Share on other sites

Sean,

 

Be sure that you put:

 

require(DIR_WS_CLASSES . 'auction_cart.php');

 

directly after:

 

require(DIR_WS_CLASSES . 'shopping_cart.php');

 

at about line 130 in your application_top.php file.

 

You currently have this inside of a conditional (if/then) statement. That will definitely cause the issue with auctionCart sometimes not being defined.

 

Also, the following error

'DIR_WS_CLASSESauction_cart.php' (include_path='.:/php/includes:/usr/share/php')

 

is caused because you placed this before the DIR_WS_CLASSES definition. (Just revert to your prior version and place it at line 130.)

Share this post


Link to post
Share on other sites
Guest

Thanks. I just changed it and I'll try it out tomorrow and let you know.

 

Now, if only you could fix my problem with my USPS shipping so easily :)

Share this post


Link to post
Share on other sites
Guest

I don't suppose that the auction cart would have messed up my shipping would it? I've been trying to get some help over here.

 

Basically, I'm on the production server, the username/pass works in another store. I enter it into this one and it doesn't work. I even completely replaced the usps.php file with another one and it doesn't work either. I'm wondering if something got messed up in the installation....

 

Any ideas where to look?

Share this post


Link to post
Share on other sites
Guest

Okay, fixed the shipping. Not sure what happened, but the Zip code in my config was wiped out.

 

I was also trying to use the USPS w/ Insurance module. Auctionblox, have you thought about using something like that? Unfortunatly the contrib out there is for MS1, and doesn't seem to work with MS2. It would be nice to be able to eliminate the "Shipping Insurance" in the auction setup, and have the Insurance as an option in the checkout. I offer insurance to everyone, and it would be nice to let them choose when the check out.

Share this post


Link to post
Share on other sites

I would think you would want to lump all of the following shipping features together:

 

1. Shipping discount for multiple items.

2. Optional/Required insurance

3. International/Domestic fixed shipping.

4. Dyanmic osCommerce shipping vs. fixed eBay shipping configuration option.

Share this post


Link to post
Share on other sites
Guest

Right now I'm attempting to use the manual piece for my auctions. But when I have multiple items and things it tends to screw things up. I have to manually calculate how much the additional shipping is, then enter it. If I enter the insurance, then it's mandatory. I'm looking to make it optional...

 

I know we talked earlier about having different fields for all the shipping. I'm still waiting to see what you come up with, because what what I envision for simplied functionality for my Buy It Now auctions, and what you may come up with may differ. But, as long as it works ;)

 

Now that I'm trying to actually use the thing, I'm getting that duplicate key error. I went back through the thread, and it looked like smitty was getting it, but it was in additional code he put in. Did we ever figure out what the problem was?

1062 - Duplicate entry '3' for key 1

 

insert into address_book (customers_id, address_book_id, entry_firstname, entry_lastname, entry_street_address, entry_postcode, entry_city, entry_country_id, entry_gender, entry_company, entry_suburb, entry_zone_id, entry_state) values ('150', '3', 'Doug', 'Reno', '1235 Leather Stocking Trail', '43054', 'Columbus', '223', 'm', '', '', '47', '')

 

[TEP STOP]

 

Side note, I don't seem to be able to delete customers from the admin. Don't know what happened. It COULD be related to that, but I don't know...

 

auctionblox,

the bit of code you gave me to fix the session id problem worked :)

Share this post


Link to post
Share on other sites

If you're using MS2, be sure that you downloaded the version that I uploaded on 10/22. I fixed that issue in that release. I think that you might be using the old version, because of your placement of the auction_cart code from your last problem. The new instructions were updated so that you probably would not have not done that.

Share this post


Link to post
Share on other sites
Guest

I'll download it again and take a look and see if I can figure out the differences and fix it...

Share this post


Link to post
Share on other sites
Guest

Hello everyone,

I have been very busy. I have been teaching myself cURL. cURL is very cool. It is extremely well at Disguising it's self as a browser and manipulating cookies. I have been able to login and get the email addresses at ebay. There is still a few bugs with the code, but this is the pot of gold at the end of the rainbow. with the email addresses we can send out automatic emails at the end of the auction.

 

:D :D :D :D :D :D

Share this post


Link to post
Share on other sites
Guest

Yeh, who's the man?

I got it!! Using cURL I am now able to parse the email addresses.

Next I need to add it to the existing code plus other minor updates.

Watch for a new "Auto update" coming soon.

 

:D :D :D :D :D :D

Share this post


Link to post
Share on other sites
Guest

Ok Auctionblox, this is where you come in. What to do with the email address ($email). We want to put it in the auction_winners table correct? We also want to be able to update it correct? Do we need a new "if" statement or can we add it to the existing one?

 

$query = tep_db_query("select ext_id from " . TABLE_AUCTION_BASKET . " where ext_id = '" . $itemnum . "'");
    	 
  	 if (tep_db_num_rows($query) > 0) {
     tep_db_query ("UPDATE " . TABLE_AUCTION_BASKET . " SET time_end = '$time_end' WHERE ext_id = '$itemnum'");
     tep_db_query ("UPDATE " . TABLE_AUCTION_BASKET . " SET price_end = '$price' WHERE ext_id = '$itemnum'");
           }
  	 
  	 else    {
     tep_db_query ("INSERT INTO " . TABLE_AUCTION_BASKET . " ( `auction_basket_id` , `auction_house_id` , `auction_item_id` , `ext_id` , `auction_winner_id` , `listing_status` , `time_start` , `time_end` , `orders_id` , `ext_title` , `ext_desc` , `quantity` , `price_start` , `price_end` , `insurance` , `shipping` , `sales_tax` , `products_id` ) VALUES ('', '1', '0', '$item', '1', '2', '$time_start', '$time_end', NULL , '$title', NULL , '1', '0.0000', '$price', '0.0000', '0.0000', '0.0000', '$products_id')");
     }

 

What do you think? ;)

Edited by smitty1

Share this post


Link to post
Share on other sites
Guest

Great to hear smitty!! Why stop at the email, just parse all the info, title, cost, shipping etc, all from eBay and have it send invoices automatically.

 

Auctionblox, I reinstalled, the newed mod, and it works like a charm. :) Now, if only I could give them an option for Insurance at checkout. Include an insurance cost, and if they select yes, add it to the shipping, else, it stays the same? Have you worked on adding US vs International and Cost for Additional items shipped?

Share this post


Link to post
Share on other sites
Guest

Found a slight snag...

 

I've had 3 people complete the checkout, and pay via Paypal. I get the email from paypal (Is there a way to add the Order # to that BTW?). I go to the Checked Out Auctions, and they are not listed, they are still in the Ended Auctions. I check the Orders, and I don't see an order for either of them. Ideas?

Share this post


Link to post
Share on other sites
Guest

I was going to do a bunch more listings tomorrow, and remove the option to pay automatically with Paypal at eBay auction end. But if this isn't working correctly, I can't do that :(

Share this post


Link to post
Share on other sites
Guest

I've had 3 people email me stating they get the following message when they try to access the auction_finder.php

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, worldwidedvds@columbus.rr.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

--------------------------------------------------------------------------------

 

Apache/1.3.27 Server at www.world-widedvds.com Port 80

 

Would this be something wrong with the code? Or something wrong with the server it's being hosted on?

Share this post


Link to post
Share on other sites
Guest

So did they get to the auction_finder page submit their email and get this message? Or they can not get to the page at all?

 

If they can not get to the page at all it sounds like a server error.

Are you linking them to https or http?

Maybe they need a browser upgrade....

 

Hope this helps. <_<

Share this post


Link to post
Share on other sites

Sean - The error you are receiving is basically a page not found. It's because the URL that's being sent in the invoice is "http://www.world-widedvds.com/auction_finder.php". But, your auction_finder.php is not located there. You will need to update auction_listing_item.php in your admin/includes/language/english folder. Update the EMAIL_TEXT definition to your http://www.world-widedvds.com/osc/catalog/auction_finder.php. (Set up a test auction and send an invoice to yourself to test.)

 

Hmmm. That's a problem -- it should have been an administrative option. Maybe someone will make it so!

 

Also, if you get that going, then remove the PayPal button so that the consumer checks out on your site and everything will flow correctly.

Share this post


Link to post
Share on other sites

Smitty1 - You need to insert/update the auction_winners table. You have to do this first to be able to get an auction_winner_id to insert into the auction_basket table. That will have to be a separate insert and update db statement. something like this:

 

for each $item_num

{

select auction_winner_id from auction_winner where email_address = $email

if count > 0

{

// save auction_winner_id from db

}

else

{

// insert new auction_winner into table

// get auction_winner_id from db

}

 

// your existing code here which uses the auction_winner_id that you created or

// retrieved from above

 

}

Share this post


Link to post
Share on other sites
I've had 3 people complete the checkout, and pay via Paypal. I get the email from paypal (Is there a way to add the Order # to that BTW?). I go to the Checked Out Auctions, and they are not listed, they are still in the Ended Auctions. I check the Orders, and I don't see an order for either of them. Ideas?

 

They did not checkout thru osc. I presume that these are the same 3 that paid via PayPal and could not use the checkout link.

Share this post


Link to post
Share on other sites
Guest

Is anyone esle having problems recieving the emial address when updating your ebay auctions. This contribution seems to be working fine after install, except for it does not retreive the winners email address. It gets all the other info from ebay but this info, anyone know how to fix this or is this how it was designed, and I need to add the email manually...

Doug

Share this post


Link to post
Share on other sites
Guest

The email sent actually says:

http://www.world-widedvds.com/osc/catalog/auction_finder.php

 

As for the Paypal payments with no orders... Here is the email I get from Paypal

Dear World-Wide DVDs,

 

This email confirms that you have received a Payment for $86.94 USD from Customer Name(CustomerName@SomWhere.com)

 

View the details of this transaction online at:

 

https://www.paypal.com/us/vst/id=XXXXXXXXXXXXXXXXX

 

 

------------------------------

Payment Details:

------------------------------

 

Total Amount: $86.94 USD

Currency: U.S. Dollars

Transaction ID: XXXXXXXXXXXXXXXXx

Total Shipping: $9.95 USD

Quantity: 1

Item Title: World-Wide DVDs

Buyer: Customer Name

 

This is the exact message I would get when someone would purchase something through the OSC website, so I know it was processed through OSC. They won one of my auctions, and they told me they completed the checkout. Their customer information was entered, but no order created.

 

I have 50 listings set to go today, I would like to get this fixed, so I can remove the Paypal button in eBay and have them checkout with OSC. But I can't do that if the Paypal payment is flaky. I'd rather not have them go through the checkout, and then have me try to figure out how to place an order in their name afterwards. Kind of defeats the purpose..

Share this post


Link to post
Share on other sites
Their customer information was entered, but no order created.

 

You need to install the PayPal IPN 0.98 for MS2 contribution (Not the PayPal that comes with the default OSC store.) That solves the problem where the user forgot to click the continue button on PayPal to register the order. (This is default OSC behavior.) I've included instructions in the installation notes for making the PayPal IPN contribution work with the Auction Sales Manager.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×