Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How to correct HTTPS setup error


bblinn

Recommended Posts

I'm setting up OSCommerce for a client. First time I've used this cart. I believe that I created an incorrect entry in a configuration setting, but now can't seem to find where to change it. We're using the host's (BlueHost) certificate. When I select "create account" as a user, the URL displays as:

"https://https//secure.bluehost.com/~{clientname}/{directory}/{OSCdirectory}/create_account.php?osCsid={number}"

(I have replaced actual names with {placeholders}.)

 

The extra "https//" is clearly where the problem is, but what do I need to edit to get rid of it.

 

When I change the URL to "https://secure.bluehost.com/~{clientname}/{directory}/{OSCdirectory}/create_account.php?osCsid={number}" the result is almost as expected, except that the CSS and all images are missing. Recommendations to resolve that would be more than welcome.

 

Thanks!

Link to comment
Share on other sites

The path is wrong which is effecting everything else.

 

It is not a good idea to use a shared certificate. It will be much better for your client if you get them to install a site specific one. So that is what I would do rather than continue on.

 

However if you want to puruse this then you need to show what you have in your configure.php file for the https setting.

Link to comment
Share on other sites

The path is wrong which is effecting everything else.

 

It is not a good idea to use a shared certificate. It will be much better for your client if you get them to install a site specific one. So that is what I would do rather than continue on.

 

However if you want to puruse this then you need to show what you have in your configure.php file for the https setting.

 

 

Yes, I know shared certificates are sub-optimal (The client is cheap. What can I say?) and it was clear to me that the path was wrong.

 

In the meantime I searched through the files and found that the problem is in configure.php. I changed the file, uploaded it, changed permissions back to 444, and all is again go.

 

Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...