Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

"Red" URL


rumi

Recommended Posts

When I go to my site the url is bright red and the padlock is flashing red. When clicking on the padlock, it say "this page contains unauthenticated contents." Below is my includes/configure file. Several times I have changes the https_server define to https://mysite.com and define enable_ssl to true but after saving it reverts back to the what it was.

Im really confused. I am using RC1, Im wondering if I uploaded the new files incorrectly since I followed Vgers Quick Install Guide which has always worked for me in the past (but that was for MS2.2.

Hope someone is brighter than I. Thanks

 

<?php

define('HTTP_SERVER', 'http://www.====.com');

define('HTTPS_SERVER', 'http://www.====.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', '=====');

define('HTTPS_COOKIE_DOMAIN', '===');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/var/www/html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '=====);

define('DB_SERVER_PASSWORD', '===);

define('DB_DATABASE', '====');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

Link to comment
Share on other sites

I should add that if you want to run the site under ssl, these are the proper settings:

 

define('HTTP_SERVER', 'http://www.====.com');

define('HTTPS_SERVER', 'https://www.====.com');

define('ENABLE_SSL', true);

 

But you can test it when SSL is not turned on by going to https://www.====.com

 

Also check that your certificate has been issued to www.====.com

Link to comment
Share on other sites

I should add that if you want to run the site under ssl, these are the proper settings:

 

define('HTTP_SERVER', 'http://www.====.com');

define('HTTPS_SERVER', 'https://www.====.com');

define('ENABLE_SSL', true);

 

But you can test it when SSL is not turned on by going to https://www.====.com

 

Also check that your certificate has been issued to www.====.com

Thank you for your post. I was trying the new release osc RC1 which I deleted; Im not having the problem anymore.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...