Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

newbie needs help with admin


kobacom

Recommended Posts

Downloaded oscommerce yesterday and got the catalog working almost immediatly But no matter what i do i cannot get the admin area to work.

it's proably something stupid but i cant find it.

 

here's the define section for catalog

 

// define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

define('HTTP_SERVER', 'http://www.mysite.co.uk');

define('HTTPS_SERVER', 'https://exchange');

define('ENABLE_SSL', 1); // ssl server enable(1)/disable(0)

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT . '/');

define('DIR_FS_LOGS', '/usr/local/apache/logs/');

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_PAYMENT_MODULES', DIR_WS_MODULES . 'payment/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

With the db connection info

 

// define our database connection

define('DB_SERVER', 'mysql.mysite.co.uk');

define('DB_SERVER_USERNAME', '*****fp');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', '*****fp');

define('USE_PCONNECT', 1);

 

And here's the same from the admin section

 

/ define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

define('HTTP_SERVER', 'http://www.mysite.co.uk');

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT . '/'); // where your pages are located on the server.. needed to delete images.. (eg, /usr/local/apache/htdocs)

define('DIR_FS_LOGS', '/usr/local/apache/logs/');

define('DIR_WS_ADMIN', '/admin/');

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

define('DIR_WS_IMAGES', DIR_WS_ADMIN . 'images/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_PAYMENT_MODULES', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG . 'includes/modules/payment/');

define('DIR_FS_SHIPPING_MODULES', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG . 'includes/modules/shipping/');

 

and the db connection

 

// define our database connection

define('DB_SERVER', $HTTP_ENV_VARS['HOSTNAME']);

define('DB_SERVER_USERNAME', '*****');

define('DB_SERVER_PASSWORD', '*****');

define('DB_DATABASE', 'catalog');

define('USE_PCONNECT', 1);

 

am i doing this the right way or have i missed something

 

Many thanks :oops:

did i do that

Link to comment
Share on other sites

Not certain, but it may be the admin config defines for DIR_FS..

 

Some servers (like mine) require the absolute paths be written this way:

 

define('DIR_FS_ADMIN', '/home/<yourname>/public_html/admin/');

 

where <yourname> identifies your account on the server. It is the same identifier that must be used in the formation of the SSL address such as

'https://hostnumber.<serverdomain>.com/~<yourname>'

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...