Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

"register_globals" issue


Guest

Recommended Posts

Well, I know this is the bazillionth time someone has had issues with this particular topic (I'm not completely forum dumb, I swear I did a search). I am, though, completely psp and e-commerce/oscommerce dumb and illiterate though.

 

Anywho, I just recently purchased a domain and hired a server. My server provides this "OsCommerce" e-commerce thingie, which is why I signed up for it in the first place. So I tried to "install" it. I didn't have to download anything, I did it through my server's cpanel and I guess it installed the whole thing automatically.

 

But I'm having this one problem with the register_globals error. The message, as you all must know by heart already, goes as following: "Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory."

 

So as the PHP illiterate I am, I went to my server's CPanel and tried to find some sort of PHP configuration (really, you have no idea of how php-dumb I am, I actually don't even know what PHP is). Well, this is what it says:

 

php.jpg

 

It also says that I don't have permission to change that, the only person who does, is my server's admin.

 

Can anyone help me... at all?

 

Sorry for being the bazillionth-and-one, but I really want to get this done. Oh, I'm also brazilian, so 1st of all - sorry for the broken english and 2nd of all - don't use too many big words ;)

 

Thank you boys!

Link to comment
Share on other sites

Download the latests version of oscommerce (RC1), just overwrite the existing files with the new ones. This version has several (security) fixes and doesn't require to have register globals enabled.

First of all, thank you very much for your help. I just downloaded the files and now I'm throwing everything @ my "shop" folder on my server. I'll see what happens hehe.

Link to comment
Share on other sites

Or drop a note to your server Admin asking them to enable register globals. They can do it for you.

 

Cheers,

Hello! Thank you very much for your help. I did try to ask my server's Admin to enable it, but well, he sucks and didn't do it haha.

Link to comment
Share on other sites

Hello! Thank you very much for your help. I did try to ask my server's Admin to enable it, but well, he sucks and didn't do it haha.

Create a file called php.ini, and upload on your catalog.

Here is the content of the file :

 

register_globals = on

 

Hope that will help you..

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...