Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation Not Working


DPAPS

Recommended Posts

Hey all,

 

I have registered a new domain, discountperformanceautoproducts.com and have uploaded all of the oscommerce files through FTP to my hosting server account, but I do not see the install web-based interface when I surf to http://www.discountperformanceautoparts.com/catalog/install.

 

All I get are raw files at the moment.

 

I am using a dedicated server with PHP 4.0 installed, MYSql, and the server is windows 2003 based, not apache.

 

Please help me to get this to work as I am under a strict deadline to get something up and running soon.

 

Thanks,

 

Brad

Link to comment
Share on other sites

I don't understand what your problem is. If you go to http://www.discountperformanceautoparts.com/catalog/install then is all ready to install. In fact I could have done it for you!!! It doesn't look although you've tried to install it yet!

 

DON'T LEAVE IT LIKE THIS - ANYONE CAN ACCESS YOUR SITE!!

 

If are inexperienced (like me!) then it may be easier if you use a Host that supports osCommerce. Then you can load/install it through cPanel and it should all work. It did for me!

Link to comment
Share on other sites

I don't understand what your problem is. If you go to http://www.discountperformanceautoparts.com/catalog/install then is all ready to install. In fact I could have done it for you!!! It doesn't look although you've tried to install it yet!

 

DON'T LEAVE IT LIKE THIS - ANYONE CAN ACCESS YOUR SITE!!

 

If are inexperienced (like me!) then it may be easier if you use a Host that supports osCommerce. Then you can load/install it through cPanel and it should all work. It did for me!

 

 

That is my point!! I can see the raw files, but in the past, when I load OsCommerce, if i go to the install directory, there is a web interface that I would follow step by step instead of the raw files. Am I missing something here?

Link to comment
Share on other sites

Brad,

 

You probably need to be aware of a few differences between UNIX and Windows servers.

 

The osC install is made for UNIX servers it appears.

 

On a UNIX server, if you just type into your browser: www.yourdomain.com

 

The server first looks for a file named: index.htm

 

If it finds it, it gets displayed. If not, it looks for a file named: index.html

 

If it finds it, it gets displayed. If not, it looks for a file named: index.php

 

If it finds it, it gets displayed. If not, I think it looks for a file named: index.asp (I could be wrong about this last one).

 

If none of those pages are found, the you get the dreaded 404 Page not found error.

 

I believe, a Windows server operates in the same fashion, however replace "index" in all the file names mentioned with "default".

 

So, in order for the install program to run automatically on a Windows server, it would need a "default.php" file, I think.

 

As I said, I believe this is how Windows servers operate.

 

If I'm full of crap, I'm sure someone will correct me.

:lol:

 

And rightly so, I might add.

;)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Hey all,

 

I have registered a new domain, discountperformanceautoproducts.com and have uploaded all of the oscommerce files through FTP to my hosting server account, but I do not see the install web-based interface when I surf to http://www.discountperformanceautoparts.com/catalog/install.

 

All I get are raw files at the moment.

 

I am using a dedicated server with PHP 4.0 installed, MYSql, and the server is windows 2003 based, not apache.

 

Please help me to get this to work as I am under a strict deadline to get something up and running soon.

 

Thanks,

 

Brad

 

 

Click on http://www.discountperformanceautoparts.co...all/install.php to start. You just had to click on the install.php file

Link to comment
Share on other sites

Click on http://www.discountperformanceautoparts.co...all/install.php to start. You just had to click on the install.php file

 

 

Thanks All.....It seems to be working now. All I have to do now is figure out what my database username and password is and I will be able to finally get this install underway. Once installed, does anyone know of any place to get some cool auto/autoparts themed templates to use that are free?

 

Thanks again

 

Brad

Link to comment
Share on other sites

  • 2 weeks later...
Thanks All.....It seems to be working now. All I have to do now is figure out what my database username and password is and I will be able to finally get this install underway. Once installed, does anyone know of any place to get some cool auto/autoparts themed templates to use that are free?

 

Thanks again

 

Brad

 

 

Call your ISP or look at your control panel that your ISP allows you access to in order to get your database domain.

 

Then you create your database and assign it a username basedon what your MySQL database server name is.

 

At least, that is what i did in my case.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...