Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Currency Reverts to Anything but UK Pounds


AndrewR

Recommended Posts

I am working on Daily CVS Snapshot 2.2 (11/16/2002) and most things are working, however when I set UK Pounds as default in Admin/Currency, it always defaults to either Nothing (0 as the displayed price), or the correct conversion for USD, even when I have only UK Pounds as the currency. The currency selector seems to work but only briefly, when I hit checkout, it reverts to USD or just shows 0 for the pounds. I have just removed USD from the currency so you can see the problem.

 

Here is the site: http://www.laser.com/comfort/catalog/default.php

 

 

Thanks in Advance

 

Andy (UK)

Link to comment
Share on other sites

Thanks to Burt's posting

http://www.oscommerce.com/forums/viewtopic.php?t=26658

 

I have now fixed it :lol: by making the following adjustment:

 

It appears the admin tool is not updating the default currency correctly, is this a bug then? :?

 

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used when changing language)

define('LANGUAGE_CURRENCY', 'GBP');

 

in catalog/includes/languages/english.php

 

Thanks Burt!!

Link to comment
Share on other sites

  • 1 month later...
:oops: i have the same thing going on with my site how did you sort it

 

pls email me a [email protected]

 

well that reply was to me and it worked then but now I am, using a newer snapshot I cant get anything other than 0 to display not even a ? sign .

 

Anyone getting this or is it just me now??

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...