Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: I am able to write to the configuration file: catalog/includes/configure.php.


mkbevan

Recommended Posts

Darn, I'm still getting the following error after my 2nd fresh install of OScommerce on a linux box.

I am using the latest build available as of this week.

 

*Warning: I am able to write to the configuration file: /catalog/includes/configure.php.

 

I've tried a few CHMOD's for this and still no dice. The error keeps showing up.

 

Is this a problem with this build? or is this an apache issue?

 

If anyone has a fix, or suggestion...feel free to reply - thanks, Mike.

Link to comment
Share on other sites

Darn, I'm still getting the following error after my 2nd fresh install of OScommerce on a linux box.

I am using the latest build available as of this week.

 

*Warning: I am able to write to the configuration file: /catalog/includes/configure.php.

 

I've tried a few CHMOD's for this and still no dice. The error keeps showing up.

 

Is this a problem with this build? or is this an apache issue?

 

If anyone has a fix, or suggestion...feel free to reply - thanks, Mike.

 

 

644 - produces same error code

444 - produces same error code

0 - produces same error code

 

What am I doing wrong here people?

Link to comment
Share on other sites

644 - produces same error code

444 - produces same error code

0 - produces same error code

 

What am I doing wrong here people?

 

OK - These are the instructions straight from the docs:

 

Post-Installation:

 

2. Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

 

I am able to CHMOD all files on my server, and I have tried this 3 times now.

 

These instructions don't work!

 

Can an Admin or someone who has done a recent install tell me what is wrong here? Please help...

Link to comment
Share on other sites

If this a version bug, does someone know where to turn off error reporting? Who needs it if it doesn't work!

 

My server info is below it helps....

 

Server Host: Database Host: localhost (127.0.0.1)

Server OS: Linux 2.6.9-11.ELsmp Database: MySQL 4.1.22-standard

Server Date: 08/22/2007 22:27:34 Datebase Date: 08/22/2007 22:27:34

Server Up Time: 22:27:34 up 23 days, 16:40, 1 user, load average: 0.12, 0.24, 0.19

HTTP Server: Apache/1.3.37 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.28 OpenSSL/0.9.7a PHP-CGI/0.1b

PHP Version: 5.2.1 (Zend: 2.2.0)

Link to comment
Share on other sites

I have a similar problem. I keep trying to change the permissions from 644 to 444 but they keep reverting to 644?? I have logged in with the main administrative account and used several different ftp clients ....

 

 

these issues seem to be related

Link to comment
Share on other sites

I had this same problem when I installed the other day and I almost pulled out my hair trying to figure it out. The solution for me ended up being really easy. I kept trying to chmod configure.php using ftp applications from 644 to 444 and it would just keep reverting back to 644. I read somewhere that someone mentioned to make sure you use your control panel when switching permissions because ftp apps can be buggy. So I logged into my cpanel and set the permissions to 444 through file manager and it finally worked. The permissions stayed at 444 and the error message disappeared.

 

Solution: Log into control panel and use file manager to change permissions.

 

If this doesn't work your issue probably extends further then the permissions on the file.

Link to comment
Share on other sites

  • 2 weeks later...

//check if the configure.php file is writeable

if (WARN_CONFIG_WRITEABLE == 'true') {

if ( (file_exists(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) && (is_writeable(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) ) {

// $messageStack->add('header', WARNING_CONFIG_FILE_WRITEABLE, 'warning');

}

}

 

Line 23 of header.php put "//" infront of $message.....

Link to comment
Share on other sites

So I logged into my cpanel and set the permissions to 444 through file manager and it finally worked. The permissions stayed at 444 and the error message disappeared.

 

Solution: Log into control panel and use file manager to change permissions.

 

If this doesn't work your issue probably extends further then the permissions on the file.

 

 

Worked for me too.

Thanks.

 

Fetch indicated 444 but file manager said it was still 644. It's the only time in years that Fetch failed to change the permissions.

Link to comment
Share on other sites

//check if the configure.php file is writeable

if (WARN_CONFIG_WRITEABLE == 'true') {

if ( (file_exists(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) && (is_writeable(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) ) {

// $messageStack->add('header', WARNING_CONFIG_FILE_WRITEABLE, 'warning');

}

}

 

Line 23 of header.php put "//" infront of $message.....

 

Thats hardly a sensible solution. That will leave the configure file writeable without being warned about it. That is a security risk.

Link to comment
Share on other sites

I had this same problem when I installed the other day and I almost pulled out my hair trying to figure it out. The solution for me ended up being really easy. I kept trying to chmod configure.php using ftp applications from 644 to 444 and it would just keep reverting back to 644. I read somewhere that someone mentioned to make sure you use your control panel when switching permissions because ftp apps can be buggy. So I logged into my cpanel and set the permissions to 444 through file manager and it finally worked. The permissions stayed at 444 and the error message disappeared.

 

Solution: Log into control panel and use file manager to change permissions.

 

If this doesn't work your issue probably extends further then the permissions on the file.

This tip saved me tonight. Thanks! :thumbsup:

* Approach the ordinary with extraordinary intent! *

Link to comment
Share on other sites

  • 2 years later...

we are now almost in 2010, and this problem came up, and the solution was to go thru the server control panel and change permissions.

 

Thanks

"The Breath becomes a stone; the stone, a plant; the plant, an animal; the animal, a man; the man, a spirit; and the spirit, a God."

Link to comment
Share on other sites

  • 3 weeks later...

I had this same problem when I installed the other day and I almost pulled out my hair trying to figure it out. The solution for me ended up being really easy. I kept trying to chmod configure.php using ftp applications from 644 to 444 and it would just keep reverting back to 644. I read somewhere that someone mentioned to make sure you use your control panel when switching permissions because ftp apps can be buggy. So I logged into my cpanel and set the permissions to 444 through file manager and it finally worked. The permissions stayed at 444 and the error message disappeared.

 

Solution: Log into control panel and use file manager to change permissions.

 

If this doesn't work your issue probably extends further then the permissions on the file.

Thank you very

i solve the problem

thank you very much

Link to comment
Share on other sites

//check if the configure.php file is writeable

if (WARN_CONFIG_WRITEABLE == 'true') {

if ( (file_exists(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) && (is_writeable(dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/includes/configure.php')) ) {

// $messageStack->add('header', WARNING_CONFIG_FILE_WRITEABLE, 'warning');

}

}

 

Line 23 of header.php put "//" infront of $message.....

 

 

As far I get it, this would not resolve the security risk but only disable the warning.

I have the same problem and consider removing the warning as I find it redundant.

 

I used FileZilla 3 and the CHMOD therein works fine with the exception that each time you update the site and try to upload accross / over this config file you will have to remember to set CHMOD 644 from 444 as FileZilla would not allow you to update it.

 

I doubt the warning is worth much except if the serverside security files aren't kept up to date.

Link to comment
Share on other sites

i have installed oscommerce on my local computer using xampp & I dont know how to reset the permissions on the catalog/includes/configure.php file - could someone point me in the (probably obvious) direction please?

 

thanks

Duncan Hutchinson

Link to comment
Share on other sites

i have installed oscommerce on my local computer using xampp & I dont know how to reset the permissions on the catalog/includes/configure.php file - could someone point me in the (probably obvious) direction please?

 

thanks

Use the file manager in your OS (if Windows use Windows Explorer), find the file, right click on it, select properties, check Read Only

Community Bootstrap Edition, Edge

 

Avoid the most asked question. See How to Secure My Site and How do I...?

Link to comment
Share on other sites

Use the file manager in your OS (if Windows use Windows Explorer), find the file, right click on it, select properties, check Read Only

 

ah well - I was looking at a much more complicated way of doing it! Thanks for you help sorted now!

 

duncan

Duncan Hutchinson

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...