Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Strange Error in admin page?


Guest

Recommended Posts

I have moved my site to another server, the webshop works perfect, but in the Admin I get this Error?

Do I need to change anything?

 

Error: Catalog images directory does not exist: /hsphere/local/home/userC/c1016200/public_html/website.com/Webshop/images/

 

Error: Backup directory does not exist. Please set this in configure.php

Backup Directory: /hsphere/local/home/userC/c1016200/public_html/website.com/Webshop/adminmarcus/backups/

 

 

The files are there, but maybe the directory "hsphere/local/home......." is wrong?

 

Please help me...

Link to comment
Share on other sites

yes, you need to edit your admin/includes/configure.php and the your-site.com/includes/configure.php file to be correct for your new server

 

HTH

"I must admit that I personally measure success in terms of the contributions an individual makes to her or his fellow human beings."

---Margaret Mead---

 

"The answer is never the answer. What's really interesting is the mystery. If you seek the mystery instead of the answer, you'll always be seeking. I've never seen anybody really find the answer -- they think they have, so they stop thinking. But the job is to seek mystery, evoke mystery, plant a garden in which strange plants grow and mysteries bloom. The need for mystery is greater than the need for an answer.

--Ken Kesey"

Link to comment
Share on other sites

Thanks for you reply!

I have done that as good as I can...

 

/hsphere/local/home/userC/c1016200/public_html/website.com/Webshop/

 

3 places in admin/includes/configure.php

1 place in includes/configure.php

 

But... I am not really sure about: /hsphere/local/home/userC/c1016200/public_html/website.com/Webshop/

 

Were do I find information to confirm that this is correct for my site?

Link to comment
Share on other sites

I have to assume you don't need this:

 

userC/c1016200/

 

call your host to confirm the info, they should help you with the configure files if they care about customer service

 

HTH

"I must admit that I personally measure success in terms of the contributions an individual makes to her or his fellow human beings."

---Margaret Mead---

 

"The answer is never the answer. What's really interesting is the mystery. If you seek the mystery instead of the answer, you'll always be seeking. I've never seen anybody really find the answer -- they think they have, so they stop thinking. But the job is to seek mystery, evoke mystery, plant a garden in which strange plants grow and mysteries bloom. The need for mystery is greater than the need for an answer.

--Ken Kesey"

Link to comment
Share on other sites

I have to assume you don't need this:

 

userC/c1016200/

 

call your host to confirm the info, they should help you with the configure files if they care about customer service

 

HTH

 

I got answer from my host... this is correct but still I get this error?

 

Error: Catalog images directory does not exist: /hsphere/local/home/userC/c1016200/public_html/website.com/Webshop/images/

 

Are there any other things I need to change???

Link to comment
Share on other sites

I'm getting this same error.

 

I have definately setup my configure.php file correctly.

 

The problem seems related to php being able to list directories. Since The File Manager gives an error:

 

Fatal error: Call to a member function read() on a non-object in /home/fhlinux170/c/clee-cycles.co.uk/user/htdocs/catalog/admin/file_manager.php on line 179

 

The Database Backup Manager gives an error:

 

Error: Backup directory does not exist. Please set this in configure.php.

 

And none of the Payment Modules are being shown. I assume because it needs to list all the files in the modules/payment directory.

 

I'm running oscommerce2.2-rc1, PHP Version 5.2.3, Apache/1.3.33

 

Any help on this would be much appreciated.

Link to comment
Share on other sites

  • 9 months later...

Hello

 

I had the same errors

 

for this error:

Error: Backup directory does not exist. Please set this in configure.php.

 

open: catalog/admin/includes/configure.php and find this line:

 

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); <-- make sure its exactly as this one

 

now go to: oscommerce\catalog\admin and create a folder and name it backups, that should fix it

 

And none of the Payment Modules are being shown. I assume because it needs to list all the files in the modules/payment directory.

 

The reason the modules arent showing up is probably because the paths that are on the configure files are wrong

 

open: oscommerce\catalog\admin\includes configure.php and oscommerce\catalog\includes configure.php and give the directories the right paths

 

eg. define('DIR_FS_CATALOG', 'D:/wos/www/oscommerce/catalog/');

 

to define('DIR_FS_CATALOG', 'F:/wos/www/oscommerce/catalog/');

 

oscommerce\catalog\includes configure.php is usually set to read only so make sure u select properties and untick the read-only button and when u have made the changes set it back to read only

 

hope this helps

Valerie B)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...