Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Payment Module


davidph

Recommended Posts

Greetings,

 

I installed the ACHD credit card module and am receiving the following error:

 

Constructor error

wsdl error: HTTP ERROR: CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

 

Warning: Cannot modify header information - headers already sent by (output started at E:\xampp\webroot\catalog\includes\modules\payment\achdCC.php:423) in E:\xampp\webroot\catalog\includes\functions\general.php on line 55

 

 

I am new to osCommerce and am not sure what is going on.

Anyone have an idea?

 

Thanks

Link to comment
Share on other sites

Some required modules are not installed on your php server.

 

Go into your osC admin -> tools -> server info

 

If we take then the error message one part at a time:

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like:

cURL support enabled

cURL Information libcurl/7.16.0 OpenSSL/0.9.8e zlib/1.2.3

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like:

OpenSSL support enabled

OpenSSL Version OpenSSL 0.9.8e 23 Feb 2007

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like (it needs to be higher than 4.3):

PHP Version: 5.2.2 (Zend: 2.2.0)

 

 

If any of these are missing then that's why it isn't working - you'll need to have a chat with your hosting company to get it enabled (or change host).

 

Tom

Link to comment
Share on other sites

Some required modules are not installed on your php server.

 

Go into your osC admin -> tools -> server info

 

If we take then the error message one part at a time:

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like:

cURL support enabled

cURL Information libcurl/7.16.0 OpenSSL/0.9.8e zlib/1.2.3

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like:

OpenSSL support enabled

OpenSSL Version OpenSSL 0.9.8e 23 Feb 2007

 

*CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS

- look for a section like (it needs to be higher than 4.3):

PHP Version: 5.2.2 (Zend: 2.2.0)

If any of these are missing then that's why it isn't working - you'll need to have a chat with your hosting company to get it enabled (or change host).

 

Tom

 

 

Thanks Tom for your help!

 

I found the OpenSSL support enabled and my PHP version is 4.4.7, which is greater than 4.3.

However, I did not find any section about cURL. We do not have a hosting company, we have our own in house web sever.

 

How do I enable something that is not showing up?

 

Thanks

Link to comment
Share on other sites

It depends on your server - I have at home apache/php running in Vista - to enable there you can simply edit the php.ini file and uncomment the line extension=php_curl.dll - I'm not sure about a linux server though

 

Tom

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...