Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

INSTALLATION PROBLEM


philk

Recommended Posts

Hello everyone,

I created a database + user, assigned the user to the database. But once i get to the /catalog/install.index page i have these messages that i really don't understand:

 

The webserver is not able to save the installation parameters to its configuration files.

 

The following files need to have their file permissions set to world-writeable (chmod 777):

 

/var/www/vhosts/girlsfromomsk.be/httpdocs/catalog/includes/configure.php

/var/www/vhosts/girlsfromomsk.be/httpdocs/catalog/admin/includes/configure.php

 

Does one of you have an idea?

thanks

phil

Link to comment
Share on other sites

The "control panel>file manager" route is preferrable as FTP can fail at this task sometimes.

 

Just something to be aware of should you try FTP and find it doesn't work.

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

The "control panel>file manager" route is preferrable as FTP can fail at this task sometimes.

 

Just something to be aware of should you try FTP and find it doesn't work.

:blush:

 

Thank you guys for your reply. I'm afraid i don't understand what you are talking about!! :blink:

Where is the control panel>file manager located?

 

philk

Link to comment
Share on other sites

When your Host (web space provider) established your account, they gave you a username and password, and a link to your "control panel".

 

It's a place where you login, and you can do things like upload/download files, change file permissions, among other things.

 

The "file manager" will be in this "control panel" somewhere.

 

They're not all "created equal".

 

You'll just have to find yours.

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

When your Host (web space provider) established your account, they gave you a username and password, and a link to your "control panel".

 

It's a place where you login, and you can do things like upload/download files, change file permissions, among other things.

 

The "file manager" will be in this "control panel" somewhere.

 

They're not all "created equal".

 

You'll just have to find yours.

:blush:

 

 

AAAAAHHHH,

i understand now!!

thank you very much!!

philk

Link to comment
Share on other sites

im having this problem when accessing the catalog after installation...

 

 

Warning: main(includes/languages/.php) [function.main]: failed to open stream: No such file or directory in /home/patstoy1/public_html/v1/includes/application_top.php on line 288

 

Fatal error: main() [function.require]: Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/patstoy1/public_html/v1/includes/application_top.php on line 288

 

how do i fix this?

Link to comment
Share on other sites

From the errors:

 

Warning: main(includes/languages/.php) [function.main]: failed to open stream: No such file or directory in /home/patstoy1/public_html/v1/includes/application_top.php on line 288

 

Fatal error: main() [function.require]: Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/patstoy1/public_html/v1/includes/application_top.php on line 288

 

It appears you have an "include" or a "require" statment with an incomplete file name. It has the ".php" extension only.

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

This is the code I have in that file around line 288:

 

	include(DIR_WS_CLASSES . 'language.php');
$lng = new language();

if (isset($HTTP_GET_VARS['language']) && tep_not_null($HTTP_GET_VARS['language'])) {
  $lng->set_language($HTTP_GET_VARS['language']);
} else {
  $lng->get_browser_language();
}

$language = $lng->language['directory'];
$languages_id = $lng->language['id'];
 }

// include the language translations
 require(DIR_WS_LANGUAGES . $language . '.php');

 

Yours may be different.

 

If not, the line to scrutinize would be:

 

require(DIR_WS_LANGUAGES . $language . '.php');

I think the variable $language may not be getting initialzed.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

I believe the correct settings should be 644 to make the error disappear.

:)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

I missed the boat on that last post.

:blush:

 

Please disregard.

 

Brain fart.

:lol:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

We've got several "messages" going on in this post.

 

I don't know about everyone else, but I'm confused....

:wacko:

 

Exactly what "message" do you get, Mike?

:unsure:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

We've got several "messages" going on in this post.

 

I don't know about everyone else, but I'm confused....

:wacko:

 

Exactly what "message" do you get, Mike?

:unsure:

 

Sorry about that!

 

Warning: I am able to write to the configuration file: /public_html/commerce/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

As I said, I tried 777 and 755, plus a few others. This only happened after upgrading to latest version.

 

Thanks,

 

Mike

Link to comment
Share on other sites

Use 644.

;)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Use 644.

;)

I tried that yesterday thinking maybe it would work (after reading your one post) and it didn't. I got the same result today. (Going through File Manager in CPanel and via Filezilla). To be sure, I did a forced redraw, and I see whether I am a guest or logged in as administrator.

 

Mike

Link to comment
Share on other sites

Just for "grins and giggles", I logged on to my site and tried 755 and 644 and I don't get any message.

 

Are you sure the permission settings are taking effect after applying them?

:unsure:

 

You could try 444, but that would put it "read only" for everyone, and you'd need to change it back to 644 before you could edit it.

 

I don't know what else to try.

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Just for "grins and giggles", I logged on to my site and tried 755 and 644 and I don't get any message.

 

Are you sure the permission settings are taking effect after applying them?

:unsure:

 

You could try 444, but that would put it "read only" for everyone, and you'd need to change it back to 644 before you could edit it.

 

I don't know what else to try.

:blush:

 

I looked at the file attributes both in Mozilla and CPanel's File Manager and they are set to 755. I'm wondering if I am the only one getting this message? It shows up both if I have not logged in yet (guest) or do log in as administrator.

 

I tried to comment out the error reporting ability in the includes/configure.php file but that doesn't make any difference. I'm thinking I managed to get a duff install of the upgrade. Since it is just a site to show people what OS Commerce can do (another person is very interested in installing it) it's not like I will lose a lot of work.

 

If you don't have any more suggestions (444 didn't work either!) I'll go that route.

 

Thanks for your help, even if it hasn't helped!

 

Mike

Link to comment
Share on other sites

All is well now. Fantastico was not completing the upgrade installation. After uninstalling and installing, a message pops up in Fantastico that I need to click here to finish setting the security. I didn't get that opportunity when upgrading.

 

Mike :thumbsup:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...