Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How to get admin to work


tonylinde

Recommended Posts

I've gone through the installation of the latest version (2.2rc1) but cannot get through to the admin screen. It keeps asking for admin account and password. I tried using the account and password set up during the installation then created a .htpasswd file pointed to by .htaccess and added a username/pwd in there but that doesn't work either. HELP!

 

Thanks,

Tony.

Link to comment
Share on other sites

I just realised that it seems to be accepting my username/pwd but still returning me to the login screen since entering the wrong username or password gives the message 'Error: Invalid administrator login attempt.' How do I get past the login screen?

Link to comment
Share on other sites

I just realised that it seems to be accepting my username/pwd but still returning me to the login screen since entering the wrong username or password gives the message 'Error: Invalid administrator login attempt.' How do I get past the login screen?

Can no-one offer any ideas?

Link to comment
Share on other sites

I've gone through the installation of the latest version (2.2rc1) but cannot get through to the admin screen. It keeps asking for admin account and password. I tried using the account and password set up during the installation then created a .htpasswd file pointed to by .htaccess and added a username/pwd in there but that doesn't work either. HELP!

 

Thanks,

Tony.

I'm stuck on this too! I installed it all with no problems (OMG!!) but this admin log in page doesn't accept any usernames/passwords created during the install or .htaccess

 

Please could someone give us a clue as it must be simple!!

 

Thanks

Julie

Link to comment
Share on other sites

Are you using SSL?

 

I'm having a problem with this too but I think the SSL is blocking everything.

Alternatively, there was a possible solution posted here (didn't work for me though):

 

http://www.oscommerce.com/forums/index.php?sho...p;#entry1118667

Thanks uksupafly

 

I looked in the database & then figured out my password. Now I can access my admin. HTH others too.

 

Julie

Link to comment
Share on other sites

I'm stuck on this too! I installed it all with no problems (OMG!!) but this admin log in page doesn't accept any usernames/passwords created during the install or .htaccess

That isn't my problem, Julie. My username/password is accepted but I am just taken straight back to the login page. It is driving me barmy!

Link to comment
Share on other sites

That isn't my problem, Julie. My username/password is accepted but I am just taken straight back to the login page. It is driving me barmy!

 

I am having the same problem - a clean install of osCommerce Online Merchant v2.2 Release Candidate 1 - the latest and only one available for download and after finally getting it to run through searching these forums for answers to other errors, I am now stuck with not being able to get into the admin.

 

Page loads, I put in username and password and then go straight back to the login page.

 

I deleted in the administrators table my details, loaded up the login page where it kindly told me there were not any administrators and for me to create an account so I could log in. I created the account (checked in the administrators table) then went to log in again and kept on going back to the login page. Sometimes I'm a dyslexic tpyer so I went through this process a few times, but no luck :(

 

Any solutions yet to this problem?

 

Thank you for your time

Link to comment
Share on other sites

I have managed to get this issue fixed - not too sure if it will work for others, but here is what worked for me:

 

In admin/includes/configure.php find (bottom of the page)

 

define('STORE_SESSIONS', '');

 

and change to

define('STORE_SESSIONS', 'mysql');

 

I have made the same change in catalog/includes/config.php

 

Good luck! :D

Link to comment
Share on other sites

Sorry - I had the same issue with Zen Cart software who helped me resolve it and I forgot to come back here and post my solution. I simply switched to using PHP v4 instead of the problematic v5.x.x (cannot remember which it was - possibly something like 5.0.1RC1 I think).

 

T.

Link to comment
Share on other sites

That isn't my problem, Julie. My username/password is accepted but I am just taken straight back to the login page. It is driving me barmy!

Yep mine kept doing that too & I was just using the wrong set of username/password...I have loads!! Any how any more technical than that I am sorry but I can't say. Hope you resolve it soon, as I know it's frustrating trying to find out the answer.

 

Julie

Link to comment
Share on other sites

  • 2 weeks later...

aaahhhh!!!! Now that I have put my store onto a production server, it is doing this again and my solution won't work on the server :angry:

 

Has anyone come up with a solution so that when you log in it will take you to the admin pages, and not loop back to the login page? (UName and Pword is correct becuase if I put in a wrong one it tells me ..... )

 

The server has PHP 4 and not the V5 - it was V5 that was on my machine that my "solution" worked for.

 

Help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...