Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error: I can not write to this file. Please set the right user permissions on:


rdrmeo

Recommended Posts

Hi,

 

When I try to open

Admin ----> Tools-------->Define Languages -----> defaultlanguage.php

 

I m getting the following error

 

Error: I can not write to this file. Please set the right user permissions on: /usr/home/xxx/htdocs/includes/languages/danish.php

 

I tried to CHMOD the files aswell as directory to 777 but still its not working. Can anyone please suggest what might be wrong?

 

Thank you

Link to comment
Share on other sites

What is the current permission? Are you using web-based file manager or do you have telnet session?

 

Cheers,

 

 

Now the permissions are set to 777, I m using FTP file manager (CuteFTP). I tried to use web-based file manager on the admin section but when I click on the file manager button it gives HTTP 404 error (webpage not found).

 

Thanks

Link to comment
Share on other sites

Kumar,

Work in reverse order, compare settings of danish.php with english.php - can you write to english.php? If yes, what are the file permission for english.php.

Can you copy english.php - as danish.php and later replace its contents?

 

/usr/home/xxx/htdocs/includes/languages/danish.php

 

Look for more reasons - not sure why you are getting 404 error. Close your ftp session, and reopen to see if you are looking at permission on server properly (and not cached information)

 

Cheers,

Best Regards,
Gaurav

Link to comment
Share on other sites

Kumar,

Work in reverse order, compare settings of danish.php with english.php - can you write to english.php? If yes, what are the file permission for english.php.

Can you copy english.php - as danish.php and later replace its contents?

 

/usr/home/xxx/htdocs/includes/languages/danish.php

 

Look for more reasons - not sure why you are getting 404 error. Close your ftp session, and reopen to see if you are looking at permission on server properly (and not cached information)

 

Cheers,

 

 

I restarted the ftp session, now filemanager is working :) when I click on the file manager it gives the following message

 

No Right Permission Access

Please contact your Webmaster to request

more access or if you found any problem.

I am using da

I checked out english.php and other php files in the directory. I am can edit all other php files except english.php, when I try to edit english.php it gives the same permission error. The permissions of all the files are same (777)

I am using danish and english languages..........in both the cases i can edit all php files except danish.php and english.php.

 

Thank you once again

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...