Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Admin links broken


Guest

Recommended Posts

To whomever can help we would appreaciate it.

 

Our admin panel is not linking correctly. For example if we click on catalog we get this:

 

http://www.mysite.com/store/admin/www.mysite.com/store/admin/categories.php?selected_box=catalog]http://www.mysite.com/store/admin/www.mysi...ted_box=catalog

 

So as you can see www.mysite.com/store/admin is duplicated. Here is our admin/includes/config file where I suspect we have the error:

 

define('HTTP_SERVER', 'www.mysite.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http//www.mysite.com/store/admin/');
 define('HTTPS_CATALOG_SERVER', 'https//www.mysite.com/store/admin/');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/content/m/y/s/mysite/html/store/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/store/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/content/m/y/s/mysite/html/store/admin/'); // absolute path required
 define('DIR_WS_CATALOG', '/store/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/content/m/y/s/mysite/html/store/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

Any ideas?

Link to comment
Share on other sites

change

define('HTTP_SERVER', 'www.mysite.com'); // eg, http://localhost - should not be empty for productive servers

to

define('HTTP_SERVER', 'http://www.mysite.com'); // eg, http://localhost - should not be empty for productive servers

 

Tom

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...