Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL NOT WORKING


isb105

Recommended Posts

hi guys im struggling with ssl certificate can anyone help

 

I installed a certificate last night and today i got a big warning sign saying that owner not recognised and also when i go on admin side to add my products they are not being added can anyone assist me please asap thanks

Link to comment
Share on other sites

May be better to post the url of your site

 

my website name is as follows: http://www.sextoyssite.co.uk

I have added the following code within public_html in htaaccess.php

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$

RewriteRule ^(.*)$ https://www.sextoyssite.co.uk/$1 [R]

 

I also added the code in public_html/admin htaccess.php

 

when i try and access normal site i get a certificate message stating that "the name on the security certificate is invalid or does not match the name of the site. the other messages have ticks in them so are fine.

In the admin section when i try to add a product it comes up with database error.

Please can you show me correct way to add the full certificate from geotrust. The code was given to me by my host.

Link to comment
Share on other sites

I ran through a fake order, and I never went to https. So you have it turned off right now. The other thing I noticed, and I don't know if this means anything, is your SSL certificate is to http://sextoyssite.co.uk and your site is http://www Someone more experienced in SSL can answer that

 

In the root .htaccess, why are you rewriting to https? Enable SSL in configure.php.

Link to comment
Share on other sites

Is Your sitehave a dedicated SSL or a shared one.

 

You need to modify Your configure.

If shared cookies cant be used so make sure on that.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

Is Your sitehave a dedicated SSL or a shared one.

 

You need to modify Your configure.

If shared cookies cant be used so make sure on that.

 

Satish

yes i turned it off deliverately because i couldnt add any products in the admin section each type i tried to add a product in database i got database error.

i added the following

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$

RewriteRule ^(.*)$ https://sextoyssite.co.uk/$1 [R]

in htaaccess thats when i got poup box giving error message and also couldnt add any products.

Would it be possible for someone to give me step by step instructions on how to enable ssl(geotrust) as i am a newbie.

I have allready successfully added the seal image which show the data and time live.

Link to comment
Share on other sites

You need to remove the .htaccess file.

 

Your ssl cert is made out to yourdomain.com and not to www.yourdomain.com so your https address in both configure.php files need to be made out that way, and the http and https_cookie_domain settings in includes/configure.php need to be set to just 'yourdomain.com'

 

Don't know why you are playing about with .htaccess for SSL.

 

Vger

Link to comment
Share on other sites

You need to remove the .htaccess file.

 

Your ssl cert is made out to yourdomain.com and not to www.yourdomain.com so your https address in both configure.php files need to be made out that way, and the http and https_cookie_domain settings in includes/configure.php need to be set to just 'yourdomain.com'

 

Don't know why you are playing about with .htaccess for SSL.

 

Vger

my host provider told me to add

 

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$

RewriteRule ^(.*)$ https://sextoyssite.co.uk/$1 [R]

in htaaccess, i did and all my images disappeared.

i am presuming this is linked to oscommerce so i need to change on the os commerce side i am scared to add the codes and change stuff incase my site completely vanishes

Link to comment
Share on other sites

k i changed the config files both in admin and catalogue but now the problem i have is that when i do a test buy on products and lcick on go to checkout i get following error message "page cannot be displayed" and also on oscommerce side it still states that i am not ssl protected and padlock is not locked can anyone please assist.

Link to comment
Share on other sites

Remove that rewrite code from your root .htaccess. Then post the top portion of your configure.php. You have something wrong there.

 

Installing SSL is very easy and straight forward with osCommerce. Your host lead you astray.

Link to comment
Share on other sites

Remove that rewrite code from your root .htaccess. Then post the top portion of your configure.php. You have something wrong there.

 

Installing SSL is very easy and straight forward with osCommerce. Your host lead you astray.

 

hi i removed the following re-write code from my htaaccess within catalogue/includes

RewriteEngine On

RewriteCond %{SERVER_PORT} !^443$

RewriteRule ^(.*)$ https://www.sextoyssite.co.uk/$1 [R]

 

the top portion of my htaaccess is as follows:

 

 

# -FrontPage-

 

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

 

<Limit GET POST>

order deny,allow

deny from all

allow from all

</Limit>

<Limit PUT DELETE>

order deny,allow

deny from all

</Limit>

AuthName sextoyssite.co.uk

AuthUserFile /homepages/32/d209920879/htdocs/public_html/_vti_pvt/service.pwd

AuthGroupFile /homepages/32/d209920879/htdocs/public_html/_vti_pvt/service.grp

 

I have sorted the config files out but when i click on checkout it states page can not be displayed and on the admin side it says "You are not protected by a secure SSL connection".

 

Please can you assist thankyou

Link to comment
Share on other sites

Post the top half or so of your includes/configure.php

The top half of my includes/configure.php is as follows

 

 

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://sextoyssite.co.uk'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://sextoyssite.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.sextoyssite.co.uk');

define('HTTPS_COOKIE_DOMAIN', 'sextoyssite.co.uk');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/kunden/homepages/32/d209920879/htdocs/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', '<removed>'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '<removed>');

define('DB_SERVER_PASSWORD', '<removed>');

define('DB_DATABASE', '<removed>');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

This is within catalogue not in admin

Link to comment
Share on other sites

remove the www for http cookies.

hi thanks for the advice for changing my username and password done that now

Unfortunatly when i took www from the cookie domain it had no affect same problem occured of no page can be displayed please can you assist.

Link to comment
Share on other sites

I see one thing, in your configure.php you need to change

define('DIR_WS_HTTPS_CATALOG', '');

to

define('DIR_WS_HTTPS_CATALOG', '/');

 

I tried to go further, but that is effecting links on the page, so it login.php won't show even when manually typing the url.

Link to comment
Share on other sites

I see one thing, in your configure.php you need to change

define('DIR_WS_HTTPS_CATALOG', '');

to

define('DIR_WS_HTTPS_CATALOG', '/');

 

I tried to go further, but that is effecting links on the page, so it login.php won't show even when manually typing the url.

 

hi as you requested i changed it but on admin side it still says at bottom You are protected by a unknown secure SSL connection please can you asssist and go through site once more to check if its secure as i can not tell

thankyou

Link to comment
Share on other sites

I know my SSL is working, but I get the same message on the admin page. On the other hand, when viewing your site, I am redirected to https, but it appears that you have something or things linked to http. Some hosts use virtual (or actual) https directories.

Link to comment
Share on other sites

I know my SSL is working, but I get the same message on the admin page. On the other hand, when viewing your site, I am redirected to https, but it appears that you have something or things linked to http. Some hosts use virtual (or actual) https directories.

 

so i guess it works fine then in your opinion thats cool then cheers for that owe you one .

Link to comment
Share on other sites

I know my SSL is working, but I get the same message on the admin page. On the other hand, when viewing your site, I am redirected to https, but it appears that you have something or things linked to http. Some hosts use virtual (or actual) https directories.

 

so i guess it works fine then in your opinion thats cool then cheers for that owe you one .

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...