Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error on Install.php


ncacia

Recommended Posts

I've just installed a fresh copy of both mySQL 5.0 and PHP 5 (using IIS 6.0). I had to create a Virtual Directory called osCommerce, and I copied all of the osCommerce data files there.

 

When I navigate my web browser to http://localhost/ocCommerce/catalog/install/index.php, I get the page with the checkmarks, indicating that my PHP version and PHP settings are OK and ready to go. I click continue, and it brings me to install.php where I input:

 

Database Server: localhost or http://localhost:3307 (since I installed mySQL to listen on that port)

Username: osCommerce_Admin

Password: the passsword I created for the Username

Database Name: osCommerce

 

When I click "Continue" on that page, I immediately receive an error at the bottom of my Internet Explorer window. Line 72, Character 9 - 'null' is null or not an object.

 

Can anyone help me with this? Sorry if this is an obvious answer, I'm relatively new to a lot of this stuff.

 

Thanks!

Link to comment
Share on other sites

  • 3 weeks later...

I'm using Apache on Windows and have the same exact problem. I also tried Firefox and Firefox gives a better error message. The exact line in question reads,

 

result.shift();

 

Firefox says, "result has no properties".

 

I hope someone can help.

 

 

 

I've just installed a fresh copy of both mySQL 5.0 and PHP 5 (using IIS 6.0). I had to create a Virtual Directory called osCommerce, and I copied all of the osCommerce data files there.

 

When I navigate my web browser to http://localhost/ocCommerce/catalog/install/index.php, I get the page with the checkmarks, indicating that my PHP version and PHP settings are OK and ready to go. I click continue, and it brings me to install.php where I input:

 

Database Server: localhost or http://localhost:3307 (since I installed mySQL to listen on that port)

Username: osCommerce_Admin

Password: the passsword I created for the Username

Database Name: osCommerce

 

When I click "Continue" on that page, I immediately receive an error at the bottom of my Internet Explorer window. Line 72, Character 9 - 'null' is null or not an object.

 

Can anyone help me with this? Sorry if this is an obvious answer, I'm relatively new to a lot of this stuff.

 

Thanks!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...