Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

404 error on administration page + security question


strunkwriter

Recommended Posts

I'm a real newbie. I thought I'd learn PHP on the fly while I work with this program. (I may be back.) :oops:

 

I have two distinct questions.

 

1. My administration page isn't showing up. (404 error.) On step 2 of the installation process (I'm using 2.2 because of the install tool), I got the following message:

 

"Warning: fopen("/home/sites/site128/web/catalog/admin/includes/configure.php", "w") - No such file or directory in /home/sites/site128/web/catalog/install/templates/pages/install_5.php on line 164

 

Warning: Supplied argument is not a valid File-Handle resource in /home/sites/site128/web/catalog/install/templates/pages/install_5.php on line 165

 

Warning: Supplied argument is not a valid File-Handle resource in /home/sites/site128/web/catalog/install/templates/pages/install_5.php on line 166

 

The configuration was successful!"

 

I'm not sure where I went wrong in the installation process. I know the root is correct. (The default catalog page comes up ok and it's on my hosts PHP documentation.) I left all of the defaults in place.

 

My host uses php4 and zend scripting language thingie. I got loads of documentation.

 

2. This question is more about security. I know I should remove the catalog/install directory. When should I do that in the installation process? I want to leave it up as long as possible in case I need to make changes, but I don't want to leave it up too long.

 

TIA.

 

Regards

StrunkWriter

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...