Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Error after uploading saved database


Guest

Recommended Posts

I installed OS commerce on a server and it worked correctly. Then I took a copy of a database from a production server with network solutions and received the following error message

 

1046 - No database selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

 

The database I saved works correctly in the production environment and the account files work both in the production environment using production database and in the test environment using the sample install database values.

 

What should I do to ensure my test environment works correctly.

 

Forget It I had created the mySQL user but didn't give it permission to the database. Yes you can throw things at me now

Link to comment
Share on other sites

  • 4 weeks later...

I'm having the same issues, i built my OScommerce store using a localhost, now I have uploaded the database to phpmyadmin and also uploaded all the files using ftp but I can't get one to see the other, I have no idea ho because I'm new to this and I get the same error:

 

1046 - No database selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

How did you solve it? ie. How do you make a mySQL user and give it the correct permisions?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...