Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Notice: Undefined index: step in c:\inetpub\wwwroot\catalog\


Dionisay

Recommended Posts

Hi guys,

I am trying to set this up localy for testing propose but as soon as run the install i get "Notice: Undefined index: step in c:inetpubwwwrootcataloginstallinstall.php on line 18"

I have searched the form but had no luck in finding an answer.

 

Can someone please help. I am ruming IIS with W2k.

 

Thanks

Link to comment
Share on other sites

why not take a look at using foxserv at www.foxserv.net

 

I find this much better in a windoze environment, if you HAVE to use windoze that is!!

 

At least 8!LL G@t3$ will be proud of ya....

 

:lol: :P

 

CC.

Link to comment
Share on other sites

Hi guys,

I am trying to set this up localy for testing propose but as soon as run the install i get "Notice: Undefined index: step in c:inetpubwwwrootcataloginstallinstall.php on line 18"

I have searched the form but had no luck in finding an answer.

 

Can someone please help. I am ruming IIS with W2k.

 

Thanks

 

Does the rest of the page show "ok", i.e. you just have a heap of notices?

Bassically your error tolerance is set to low in your php.ini .

Oscommerce like half the php scripts require you turn notice error messages off.

find the "php.ini" file in winnt directory.

open and search for "error_reporting"

yours is most likely set to

error_reporting = E_ALL

so change to

error_reporting = E_ALL & ~E_NOTICE

 

also check this setting

register_globals = on

Link to comment
Share on other sites

Hi guys,

I am trying to set this up localy for testing propose but as soon as run the install i get "Notice: Undefined index: step in c:inetpubwwwrootcataloginstallinstall.php on line 18"

I have searched the form but had no luck in finding an answer.

 

Can someone please help. I am ruming IIS with W2k.

 

Thanks

 

Does the rest of the page show "ok", i.e. you just have a heap of notices?

Bassically your error tolerance is set to low in your php.ini .

Oscommerce like half the php scripts require you turn notice error messages off.

find the "php.ini" file in winnt directory.

open and search for "error_reporting"

yours is most likely set to

error_reporting = E_ALL

so change to

error_reporting = E_ALL & ~E_NOTICE

 

also check this setting

register_globals = on

 

Thanks for your reply.

The page was full of errors.

That was the problem.

 

Anyway I got it going with this server bundle I got from Hotscripts.

It hade Apache, PHP, Mysql.

It saved me...

 

So did you though. Every day you just learn something new.

Once again thanks.

 

PS. Were abouts are you located in Australia. I am in Brisbane...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...