Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installing 2.2 and the register globals fun


methonis

Recommended Posts

Hi all,

 

Wondering if you can help. I just downloaded oscom 2.2, when I navigated to the install page all I get is this:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

So, obviously I go into my php.ini file, and sure enough, globals was off. So I turned the on, restarted my apache server, and then tried to load the page. Still the same error. I double checked that I had saved php.ini with the changes, restarted my whole computer, brought up all my services, and still the same error. Any ideas?

Link to comment
Share on other sites

Create a phpinfo(); file, look at the first table.. bottom line it says WHICH php.ini it is actually reading... and it wouldn't surprise me if you were editing another ini :)

"Politics is the art of preventing people from taking part in affairs which properly concern them"

Link to comment
Share on other sites

I did the phpinfo() and it WAS pointing to the file I had edited. Just for good measure though, I search my hard drive for all instances of php.ini. I found another one tucked in a totally different filebase, but modified the register_globals setting in it anyway, and now the install worked *shrug* I guess I really don't need to understand as long as it worked! :P Thanks for the help, I'm sure I'll be posting a lot in the future. It's nice to see a forum with people who actually help! Yay! :P

 

Meth

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...