Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Problems with osCommerce on Hostway.com


Recommended Posts

I am having intermittent problems with an installation of osCommerce hosted by Hostway.com.


Here's the scenario:


Hostway runs PHP as CGI rather than as an Apache mod.


We are using a shared SSL cert.


To run use PHP with SSL in this environment, Hostway tells me that I have to change all of my secure pages' extensions from .PHP to .SPHP and then add the following to the .htaccess file in the web root:



To run PHP scripts on our secure servers as your master user and

not the user "nobody" you will need to create a mime-type for your

account. You can add this mime-type using the .htaccess file:


-----begin snipet-----

AddHandler ssl-php .sphp

Action ssl-php /<domain>/cgi-bin/php

-----end snipet-------

**Above <domain> is domain without .com .net .org**


The .htaccess usually would reside in your "www" directory.


I have found that when I follow these directions exactly, the pages cannot be found. changing the above snipet from /<domain>/cgi-bin/php to /cgi-bin/php seems to work better.


So, here is the problem, Once I have made the changes mentioned above, some users are able to use the site just fine, while others are unable to login. Of course, if they cannot login, they can't buy anything (big problem).


You can see the site and try it out for yourself at http://www.doublel.com.


One final note: If SSL is turned off, the problem disappears completely.


I really need to get this resolved quickly. Any and all advice will be greatly appreciated.




Link to comment
Share on other sites

I just signed on with hostway.com yesterday, because my former hosting company could not provide the right configuration to use OScommerce. I thought that I had done all the right research- but based on your post Chris, I am now really worried. I was getting ready to start installing ver. 2.2 now that our site is up and running.


I am sorry that I am not posting any assistance for you, but I am just really interested to know if and how you end up solving this problem. I will let you know how things go- and if I run into the same problems. This is so distressing though, because I needed to get this site up asap, hence the hosting company change.


Did I choose the wrong host?! :cry:

Link to comment
Share on other sites

Chris and Catherine,


I was having the same problem with Hostway. I looked through almost all Forum and could not find the straight forward way to solve the issue.


What I could do, was to trick OSC and Explorer in setting login.php page to NONSSL when the page checks for the user. This way, when you go to login.php page a user will see a lock on the bottom and will think that he is sent to a secure page. However when the guy presses LOGIN button he is thrown to an unsecure page which works perfectly fine.


In this case I did NOT need to have .htaccess page.


So, these are the steps:


1. Keep all pages as they were with .php extensions (if you changed them due to advises from other Forum members)

2. Find the line

<?php echo tep_draw_form('login', tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL')); ?><table border="0" width="100%" cellspacing="0" cellpadding="2">

in the login.php page and change SSL to NONSSL


Everything should work now.


*** In case something doesn't work (it may since I've made so many changes, trying to solve this problem) post your reply here ***



Denis Stankovski



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...