Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.



Recommended Posts

I didnt realize the extent of my problem until I looked into it more. My entire admin is messed up. Take a look here:



I dont get it...for some reason its not replacing variables with the right values. Ive tried reinstalling, checked all my files, etc. need some other suggestions ASAP. Dont hesitate to suggest something.

Link to comment
Share on other sites

This is what I have been trying to tell you.


1 Check that your link to your server is correct.


2 Make sure that there is not an .htaccess file that might be in the root somewhere controlling or redirecting things that could be conflicting with the configure.php


3 Check that your configure.php files are in fact using the right paths to work on your servers.


Example: I cannot use the $DOCUMENT_ROOT I have to spell this out to my actual root of:




I can, however, use $DOCUMENT_ROOT on another server where it resolves correctly.


On some servers where I have seen problem like this, it is due to an .htaccess file in the root that could not be seen from the FTP program but was there never-the-less and causing problems on redirects etc.


CPanel, if you have one, or telnetting into your account is another method of seeing the .htaccess files.


Do not just delete it if you find it. Rename it or back it up in some manner so you are not breaking something else in the process.


Then on the virtual link to your site, make sure that this was set up correctly on your server.


Example: you login to one server but your site is another name, hence a virtual server link has been setup to allow this to work.


After you replaced the language files with the right files, I could not see anything that was obviously wrong with your setup.


Now that you are using a different layout, make sure you edited your configure.php files to match the new layout.


And last, if you could keep this on the same thread, perhaps it will help in diagnosing the problems to keep all the problems/attemps in one area :D

Link to comment
Share on other sites

Ive tried everything youve listed and I still cant get it to work properly. Could you double check it? I have like 2 catalogs and admins setup now to make sure I did it right and both installs did the exact same thing regardless of modifications

Link to comment
Share on other sites

Also check when you are uploading the files that you are doing so in Binary and not with auto or something.


Your catalog shows an error on line 1350 in application_top.php


Either your editor is not saving this clean or the upload is messing it up there are less than 500 lines in that file :shock:

Link to comment
Share on other sites



Ive tried what you said to do a thousand times and I still cant make it work. Will you please try? or give me another suggestion. For some reason it wont load any of the stuff in /usr/home/illstreet/public_html/admin/includes/languages/english/index.php

Link to comment
Share on other sites

what does this setting say


define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

in admin/includes/configure.php ?


Everything but languages seem to be working there.


Also as Linda had mentioned there is defintely something ODD with your


catalog/include/application_top.php file.

Mine is only 454 lines long, yours is 1350...?


There error mesage I got to get this:

Warning: Cannot add header information - headers already sent by (output started at /usr/home/illstreet/public_html/catalog/includes/application_top.php:1350) in /usr/home/illstreet/public_html/catalog/includes/functions/general.php on line 23


also the file /usr/home/illstreet/public_html/admin/includes/languages/english/index.php

Does it look ok when you view it?


I wonder if its a permission thing, its readable to all groups right?

like user/group/world?

Link to comment
Share on other sites

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


There are 451 lines in catalog/includes/application_top.php

There are 251 lines in admin/includes/application_top.php


I'll check ownership tonight...that could be it possibly

Link to comment
Share on other sites

  • 4 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...