Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How can I put links into product description whilst maintaining session ID


Guest

Recommended Posts

Hello All

 

My client wants to cross link between products on their site from links in the product description.

 

They were just inserting links using the WYSIWYG but this meant they lost the session ID as the customer lost the contents of their cart.

 

Is there anyway they can link between products from with the product description without losing the session ID?

 

Thanks

 

Paul

Link to comment
Share on other sites

Take a look at the embed links contribution.

 

Jack

 

Thanks Jack, I'll give it a look.

 

Cheers

 

Paul

Link to comment
Share on other sites

Thanks Jack, I'll give it a look.

 

Cheers

 

Paul

 

Hello Jack/All

 

I've installed the contrib and all is working, there is one small bug however which doesn't stop the site working but is annoying none the less.

 

Basically the URL in the address bar comes out strange when you click the links in the product descriptions, they carry the session ID but they look odd, best described in an example.

 

A link I would expect to look like this:

 

http://www.fasteronline.co.uk/Thule-thule-...2686edefa1fb0c7

 

In fact comes out like this:

 

http://www.fasteronline.co.uk/admin/http:/...2686edefa1fb0c7

 

Adding http://www.fasteronline.co.uk/admin/ to the beginning.

 

You can see the link on this page

 

I am adding the link as instructed in the contrib, clicking insert link and in this case adding the link below:

 

%%+Thule-thule-5451-roof-mount-single-wheel-carrier-p-2187.html%%-

 

I'm guessing that there is some hard coded URL somewhere on the site that is causing this.

 

Basically I inherited this site and when I checked I found loads of hard coded links and and other bugs (most of which are now fixed).

 

Does anyone know what might bit of code might be causing this and where I might find it?

 

Thanks

 

Paul

Link to comment
Share on other sites

I haven't used the contribution in some time but, according to the instructions, the link code should be (using your information of course)

a <a href="%%+product_info.php?products_id=123%%-">long-sleeved version</a>.</

It seems you have forgotten to include all of the code. If that doesn't fix the problem, I suggest posting the question in the support thread for that contribution. That is where you will get the most support for it.

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Hello Jack

 

The WYSIWYG will write the code in the format you mention once I type what I mentioned in the link field.

 

I need to get it working using the WYSIWYG as this is what the client uses.

 

No worries anyway - thanks for putting me onto the contrib in the first place.

 

I'll take this to the specific contrib forum.

 

Cheers

 

Paul

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...