Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Stuck at Step 2


Guest

Recommended Posts

Upon uploading all my Os Commerce files I got that wonderful register globals message. I have overided the files using the latest contrib but now I am unable to proceed beyond Step 2. The database structure is not constructed and nothing happens - I just navigate to the same page over and over again

 

http://www.mindseyemidlands.co.uk/oscommer...all/install.php

 

 

hi there,

 

the link doesnt work above. What does the message in red say?

Link to comment
Share on other sites

hi there,

 

the link doesnt work above. What does the message in red say?

 

 

Hi denzel. I am trying to upload the files again so the link isn't there any more. There was no red warning message- when i clicked continue it just went to the same page where it asks you if you want to Import Catalog Database and have Automatic Conbfiguration - My host has me set up with register globals off and i cannot do anything to change that (not that I would want to for security reasons). I uploaded the patch for register globals fix but the same thing happens

 

I have now uploaded the files again:

 

http://www.mindseyemidlands.co.uk/icommiss...all/install.php

Link to comment
Share on other sites

Hi denzel. I am trying to upload the files again so the link isn't there any more. There was no red warning message- when i clicked continue it just went to the same page where it asks you if you want to Import Catalog Database and have Automatic Conbfiguration - My host has me set up with register globals off and i cannot do anything to change that (not that I would want to for security reasons). I uploaded the patch for register globals fix but the same thing happens

 

I have now uploaded the files again:

 

http://www.mindseyemidlands.co.uk/icommiss...all/install.php

 

osCommerce uses HTTP_GET_VARS and HTTP_POST_VARS

 

Tjeck if register_long_arrays is set:

register_long_arrays = On

Link to comment
Share on other sites

osCommerce uses HTTP_GET_VARS and HTTP_POST_VARS

 

Tjeck if register_long_arrays is set:

register_long_arrays = On

 

I have a shared host and i am not permitted to change register_long_arrays or register_globals- both of which are off at the moment

Link to comment
Share on other sites

I have a shared host and i am not permitted to change register_long_arrays or register_globals

 

If you cannot turn register_long_arrays to 'on' then your present hosting is not suitable for osCommerce.

 

Vger

Link to comment
Share on other sites

If you cannot turn register_long_arrays to 'on' then your present hosting is not suitable for osCommerce.

 

Vger

 

Does this mean my hosting is not suitable for Xen cart either? Xen cart is based on OS Commerce I notice but does have a modification in place to handle register globals off. Although in the download file I cannnot see an install.php file for Xen nor is their much support on the site- what is the next best option?

Link to comment
Share on other sites

A different hosting company!

 

Vger

 

if my host can activate register_lon_arrays will the problem I have cease to exist?

Link to comment
Share on other sites

I have spoken to my web hsot and they dsay I can change registr_long_arrays- all i have to do is make a .ht_access file. How do i do this , what syntax is needed and where do i upload it to?

Link to comment
Share on other sites

I am having the exact same problem, Step 2 install page just keeps refreshing.

 

You say to add:

 

register_globals = on

register_long_arrays = on

 

............to the php.ini file - which one, I can found three or four of them in different folders.......

 

When I create a .htaccess file I get an error, could you type exactly what to add to the .htaccess file, where and which one, because I can find a few of them in different places too ;)

 

 

This is also having installed said patch to get registar_globals error to go away.....

Link to comment
Share on other sites

Hi people,

I can confirm that the two Register settings made it possible for me to get to Step 3.

 

To those who do not know it, the shell command

 show if you've successfully modified the right php.ini file. Usually, php.ini is in your /etc directory, but newer installations of php tend to put it in /usr/lib/. You might want to link /usr/lib/php.ini to /etc/php.ini so to have only one php.ini (the useful one).

 

As php is an Apache module as well, you must restart Apache for your new php.ini settings to be effective.

 

Regards

Natan

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...