Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


denzel2364

Recommended Posts

Typical, loads of info, but none for my situation.

 

i have already had this problem with my /catalog folder so i corrected it.

 

Next i have installed a seperate sub domain and uploaded a template. However it comes up with the register global error. Therefore all the info on the web show add an php.ini folder to public_html but it comes up with a 500 internal error.

 

i have tried adding it to the subdomian itself but no luck.

 

any advice?

Link to comment
Share on other sites

You will need to enable register_globals in the php.ini of your server.

It depends on the way your server is configured is my guess.

Normally register_globals is enabled in all hosts(otherwise you wouldnt be able to install oscommerce).

If you mentioned what type of host you are using shared or dedicated it would be helpful

For shared hosting i think you will need to contact support and request them to enable register_globals.

If you have root access you need to find the php.ini file yourself and change it.

Link to comment
Share on other sites

i was getting that error too- r u using godaddy?? b/c they told me to download the software that they had for oscommerce throguh their "hosting metropolis" and all of a sudden instead of that messge, i got that magical "install" button that i heard so much about.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...