Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Come Out from Behind!


transmutation

Recommended Posts

Hello Kids! I have installed osCommerce in the catalog folder as described in the installation instructions ... but now we've decided we want to move the catalog into the root. Can this be done without screwing everything up?

 

Is this like sooo easy that people are embarrassed to answer? :blush:

Link to comment
Share on other sites

I tried this when I started my first osC site not so long ago, just moving the files up a level is not a good idea as it does screw everything up. I'm sure there are ways around this but I took the easy option and decided to add a very small php page in the root directory which redirects users to the main page straight away.

 

Again, not sure if this is a good thing as still learning myself. If anyone else has some ideas on this would like to hear about it.

Link to comment
Share on other sites

Actually it isn't difficult to do.

 

1. Download all of your folder/files and upload again to the root

2. Edit both configure.php files in the root website and take out the 'catalog/' part of the paths

3. Put a 301 Permanent .htaccess redirect in the catalog folder, so that people get redirected back to the root.

 

If you put a meta tag refresh redirect in a file it will get you punished by search engines - they don't like them at all.

 

Vger

Link to comment
Share on other sites

Put this code in a .htaccess file in your catalog folder after you've moved the website to the root:

 

redirect 301 /catalog/ http://www.your_domain.com/

 

Obviously change 'your_domain.com' to your real domain.

 

Vger

Link to comment
Share on other sites

  • 2 weeks later...
Actually it isn't difficult to do.

 

1. Download all of your folder/files and upload again to the root

2. Edit both configure.php files in the root website and take out the 'catalog/' part of the paths

3. Put a 301 Permanent .htaccess redirect in the catalog folder, so that people get redirected back to the root.

 

If you put a meta tag refresh redirect in a file it will get you punished by search engines - they don't like them at all.

 

Vger

YIKES! BIG Problems .... if you go to www.uproarentertainment.com you'll see ... http://www.uproarentertainment.comdir_ws_h...products_id=271

Link to comment
Share on other sites

YIKES! BIG Problems .... if you go to www.uproarentertainment.com you'll see ... http://www.uproarentertainment.comdir_ws_h...products_id=271

Did you follow each step mentioned above by Vger? You should not have any issues if you did.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Link to comment
Share on other sites

Yes.

I see a ton of path problems in your store. How did you have your store setup previously? In order to upload to the root directory, you should have FTP'd the entire contents of the folder that contained all of your store files (maybe "catalog"?) into your public_html folder. I am seeing the path going to: http://www.uproarentertainment.comdir_ws_h...talogindex.php/

You should have:

http://www.uproarentertainment.com/index.php

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Link to comment
Share on other sites

I see a ton of path problems in your store. How did you have your store setup previously? In order to upload to the root directory, you should have FTP'd the entire contents of the folder that contained all of your store files (maybe "catalog"?) into your public_html folder. I am seeing the path going to: http://www.uproarentertainment.comdir_ws_h...talogindex.php/

You should have:

http://www.uproarentertainment.com/index.php

 

Well, that's what I thought I did.

I had initially installed osCommerce to a folder named /catalog/ When I uploaded the template I bought I had image problems. I resolved those by the folks I purchased it from. I got the site working fine and decided I didn't want to have a separate home page. BAD IDEA. So I followed the instrs to bring it out and this happened. At this point I am ready to give up. I feel so stupid. So many people have use osCommerce without these problems.... GRRRRRR

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...