Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

can you get round register globals


stevi1983

Recommended Posts

This question has been done to death and i have tried every option and therefore think I can not use oscommerce on the server. I emailed my webhost and they said they will not switch on register globals. I have added the php.inin file, i have tried the register globals patch and have had no luck what so ever. Does this mean that I will not be able to use oscommerce? If there is anything else I can try can anyone let me know. Many thanks in advance.

Link to comment
Share on other sites

I managed to finally get it to work. It has taken me a weke but I have finally got there. If anyone out there has tried php.ini and it doesnt work try this link:- http://www.oscommerce.com/community/contri...5/search,global. Download the turn on script and download it to teh admin section of oscommerce. This should work as it did for me.

Link to comment
Share on other sites

I had the same problem I know you got it to work, I just thought you might be interested to hear how I did it,

 

Through my file manager on the server I created a text file in "Admin" and "Calalog" and called them both "php.ini" and put the text

 

register_globals = On;

 

into both files. Sorted.

 

Hope this is of some help.

 

Johnny.

Link to comment
Share on other sites

I had the same problem I know you got it to work, I just thought you might be interested to hear how I did it,

 

Through my file manager on the server I created a text file in "Admin" and "Calalog" and called them both "php.ini" and put the text

 

register_globals = On;

 

into both files. Sorted.

 

Hope this is of some help.

 

Johnny.

 

I got past this but now having trouble with the admin section was it ok for you mate?

 

Steve

Link to comment
Share on other sites

  • 2 weeks later...
I got past this but now having trouble with the admin section was it ok for you mate?

 

Steve

 

It would help if I could find the catalog directory! Where did they hide that thing? :blush:

Link to comment
Share on other sites

  • 2 weeks later...
I had the same problem I know you got it to work, I just thought you might be interested to hear how I did it,

 

Through my file manager on the server I created a text file in "Admin" and "Calalog" and called them both "php.ini" and put the text

 

register_globals = On;

 

into both files. Sorted.

 

Hope this is of some help.

 

Johnny.

 

Thanks for the tip.

Sorted mine.

Link to comment
Share on other sites

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I got the above message when my hosting company upgraded their PHP

 

Version from 4.4.x to 5.2.x.

 

I opened the htaccess and found this -->

 

<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

 

So, i just change mod_php4.c to mod_php5.c and its WORKED!! I hope this

 

will help :))

Link to comment
Share on other sites

  • 4 months later...
I had the same problem I know you got it to work, I just thought you might be interested to hear how I did it,

 

Through my file manager on the server I created a text file in "Admin" and "Calalog" and called them both "php.ini" and put the text

 

register_globals = On;

 

into both files. Sorted.

 

Hope this is of some help.

 

Johnny.

 

 

This totally worked for me. Only, I didn't have a catalog file so I just put one php.ini into my root folder, the one with www on it.

 

Thanks so much!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...