Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Setting the 777 code


alcodesigns

Recommended Posts

Hello!

 

I just installed OSC on 2 servers and I was unsuccessful when it came to these steps. I'm not a PHP expert (learning as I go along), but have the very basic understanding of it. However, I couldn't figure these steps out and I need help or maybe an illustration highlighting where I'm supposed to change this code. Both admin folders are password-protected, but have not activated the SSL certificate in neither one, that's my next step, might need help there too. Not sure if that will be connected to this in any way.

 

 

1. Rename the catalog/install folder or delete it. <---DONE!

2. Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

3. Set the permissions on catalog/images directory to 777

4. Set the permissions on admin/images/graphs directory to 777

5. Create the directory admin/backups and set the permissions to 777 (this is the folder to store the database backup of your store in the "Tools" section of the store admin).

 

 

Please help! :blink:

 

Thank you in advance for your help!

Link to comment
Share on other sites

Hello!

 

I just installed OSC on 2 servers and I was unsuccessful when it came to these steps. I'm not a PHP expert (learning as I go along), but have the very basic understanding of it. However, I couldn't figure these steps out and I need help or maybe an illustration highlighting where I'm supposed to change this code. Both admin folders are password-protected, but have not activated the SSL certificate in neither one, that's my next step, might need help there too. Not sure if that will be connected to this in any way.

1. Rename the catalog/install folder or delete it. <---DONE!

2. Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

3. Set the permissions on catalog/images directory to 777

4. Set the permissions on admin/images/graphs directory to 777

5. Create the directory admin/backups and set the permissions to 777 (this is the folder to store the database backup of your store in the "Tools" section of the store admin).

Please help! :blink:

 

Thank you in advance for your help!

Some ftp programs let you change permissions (eg filezilla), otherwise use the file manger in your web hosts control panel.

 

It is similar to making files read only in windows environment, but with more options.

Link to comment
Share on other sites

Some ftp programs let you change permissions (eg filezilla), otherwise use the file manger in your web hosts control panel.

 

It is similar to making files read only in windows environment, but with more options.

 

 

Thanks so much, I finally got it, so it's all set! :thumbsup:

Link to comment
Share on other sites

log in to Cpanel, and goto file manager, find the folder you want (clicking icon opens folder - clicking name selects folder)

 

On the right (when its selected) there is an option to set permissions on a file or folder - click that link. Then Tick / untick boxes here until 3 digit code reads as per instructions then click OK or apply.

 

Note: 777 = all boxes ticked (on all columns, the bottom tickbox = 1, middle tickbox = 2, top tickbox = 4 : they add vertically to give the chmod code)

 

do all required ones as you said in the first post and you should be good to go!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...