Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FAQ System Contribution Issue


thecustomshop

Recommended Posts

FAQ System

Contribution: http://www.oscommerce.com/community/contributions,1948

 

Issue:

Code loded fine, and for the most part on the users end, the system is fine. On the admin side, when you select the FAQ Manager, the manager is pretty confused with errors. For example....

 

Under FAQ Manager, there is a line that reads...

" 0) { while (list($key, $val) = each($data)) { $no % 2 ? $bgcolor="#DEE4E8" : $bgcolor="#F0F1F1"; ?> "

 

As can be seen in the photo below. The list does not show the two temporary default FAQ questions listed, and the empty feature does not appear to be correct either.

 

Any thoughts?

 

FAQerror.jpg

Link to comment
Share on other sites

That didnt change whats listed above. Any other suggestions?

It would not if you are on php4+, it would on php5+.

 

The error indicates that the start of the php section is not being detected.

 

The code is in that file, so, sorry, I don't know.

Link to comment
Share on other sites

Ok, with your help though, I went in to faq_list.php and found 3 more areas requiring <?php to be inserted. Problem solved. Thank you!!

No problem, well done in solving the problem.

 

It is a problem that I have come across with older contribs. I will have to check my other files. My test site is php 5, my store is php 4.

Link to comment
Share on other sites

any idea or any suggestion how to implement FAQ system per product?

 

I.e.

Customer asks a question via product page and question goes to database and then together with admin answer it is displayed on product page. With this, customers could see what was already asked and answered. No need to answer same questions anymore ...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...