Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

white space on some pages only


mikecan

Recommended Posts

Sorry - I don;t see what you are referring to.

thanks for replying:

In the top header do you not get a white space to the far right? when you view main page and then again on a main category page? If you look at an info page such as shipping,or even a product page, look to the right and see how nice and tight it all is.

thanks again, mike

Link to comment
Share on other sites

It's the table processing in IE - this is very common - there are posts for hackless css - you add another stylesheet for IE right after the orginal.

Nothing unreal exists

Link to comment
Share on other sites

no you don't add extra stylesheets for no reason. You have to fix your stylesheet.css

 

First of all you're inserting invalid characters in your stylesheet all over the place. For example

color: #FFFFFF; //#FAEBD7;

background: #6495ED;//#DAA520;//#9370DB;//#FF4500;//#ffffff; //#FFEFD5; //#F3F1E0;

 

CSS does not accept // as a comment notation. You have to use /* */

Link to comment
Share on other sites

no you don't add extra stylesheets for no reason. You have to fix your stylesheet.css

 

First of all you're inserting invalid characters in your stylesheet all over the place. For example

color: #FFFFFF; //#FAEBD7;

background: #6495ED;//#DAA520;//#9370DB;//#FF4500;//#ffffff; //#FFEFD5; //#F3F1E0;

 

CSS does not accept // as a comment notation. You have to use /* */

thanks Mark,

I have just been playing around with different colors and didin't realize the effect it would have.

I will clean it up and see what happens.

thanks again, mike

Link to comment
Share on other sites

no you don't add extra stylesheets for no reason. You have to fix your stylesheet.css

 

First of all you're inserting invalid characters in your stylesheet all over the place. For example

color: #FFFFFF; //#FAEBD7;

background: #6495ED;//#DAA520;//#9370DB;//#FF4500;//#ffffff; //#FFEFD5; //#F3F1E0;

 

CSS does not accept // as a comment notation. You have to use /* */

Mark;

how do you see my stylesheet? I did a "view source " and it dosen't come up, how do you view css?

thnks

Link to comment
Share on other sites

  • 4 weeks later...
thanks Mark,

I have just been playing around with different colors and didin't realize the effect it would have.

I will clean it up and see what happens.

thanks again, mike

I have cleaned up the stylesheet, yet I still get a white space in the header only on the main page and category page?

Any ideas?

thnx, mike <_<

Link to comment
Share on other sites

Viewing your source code in IE --> culprit :)

 

<div class="fixcenter">
<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr class="header">
   <td valign="center"><a href="http://filcorgourmet.com/index.php"><img src="images/blue_filcor_logo.bmp" border="0" alt="Filcor Inc. Gourmet Importers & Distributors" title=" Filcor Inc. Gourmet Importers & Distributors "></a> </td>
   <[b]td align="right" valign="bottom"[color="#8B0000"]>  <[/color]/td>[/b]

 

There are 2 spaces in this table cell.

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

  • 2 weeks later...
Viewing your source code in IE --> culprit :)

 

<div class="fixcenter">
<table border="0" width="100%" cellspacing="0" cellpadding="0">
 <tr class="header">
   <td valign="center"><a href="http://filcorgourmet.com/index.php"><img src="images/blue_filcor_logo.bmp" border="0" alt="Filcor Inc. Gourmet Importers & Distributors" title=" Filcor Inc. Gourmet Importers & Distributors "></a> </td>
   <[b]td align="right" valign="bottom"[color="#8B0000"]>  <[/color]/td>[/b]

 

There are 2 spaces in this table cell.

 

jon

Jon:

thanks for your reply.

I have done a right click view source and nothing comes up?

I have looked at catalog/includes/header.php and I still don't see what you see (posted).

Below is the code I have in header.php area you are suggesting. I removed the 2 &nbsp: at the bottom but didn't do anything, I thought it might have to do with cell spacing or padding? (somewhere else?)

thanks again

Mike

 

<div class="fixcenter">

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr class="header">

<td valign="center"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'blue_filcor_logo.bmp','Filcor Inc. Gourmet Importers & Distributors'). '</a>'; ?></td>

<td align="right" valign="bottom"><?php echo//'<a href="' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_account.gif', HEADER_TITLE_MY_ACCOUNT) . '</a>  <a href="' . tep_href_link(FILENAME_SHOPPING_CART) . '">' . tep_image(DIR_WS_IMAGES . 'header_cart.gif', HEADER_TITLE_CART_CONTENTS) . '</a>  <a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') . '">' . tep_image(DIR_WS_IMAGES . 'header_checkout.gif', HEADER_TITLE_CHECKOUT) . '</a>'; ?>  </td>

</tr>

</table>

Link to comment
Share on other sites

includes/header.php

 

Try this. I have eliminated all TDs except for the TD that holds your logo.

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
<tr class="header">
<td valign="center"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'blue_filcor_logo.bmp' , 'Filcor Inc. Gourmet Importers & Distributors') .  '</a>'; ?></td>
</tr>
</table>

 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

includes/header.php

 

Try this. I have eliminated all TDs except for the TD that holds your logo.

 

<table border="0" width="100%" cellspacing="0" cellpadding="0">
<tr class="header">
<td valign="center"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image(DIR_WS_IMAGES . 'blue_filcor_logo.bmp' , 'Filcor Inc. Gourmet Importers & Distributors') .  '</a>'; ?></td>
</tr>
</table>

 

jon

thanks Jon, but didn't work.

why would it be only on some pages like index and main category pages and not on product page? or privacy or shipping etc? thanks again, mike

Link to comment
Share on other sites

thanks Jon, but didn't work.

why would it be only on some pages like index and main category pages and not on product page? or privacy or shipping etc? thanks again, mike

any ideas??

thnx

Link to comment
Share on other sites

Sometimes it helps to view the source code of a page that works (example: crespi) and a page that doesn't (index.php). In your index.php, there is a table width specified at 760. In your crespi page, that same table is specified at 100%, the cellspacing & padding are 3. I think if you change your index.php 760 table width to 100% and cellspacing & padding to 3, your problem may be resolved.

 

You may very well be using a template. Look for that 760 there. If not, open index.php in a text editor and look for this:

 

<table border="0" width="100%" height="25" cellspacing="0" cellpadding="0">
 <tr class="headerNavigation">
   <td class="headerNavigation">  <a href="http://filcorgourmet.com/index.php" class="headerNavigation">Home</a></td>
   <td align="right" class="headerNavigation"><a href="http://filcorgourmet.com/account.php" class="headerNavigation">My Account</a>  |  <a href="http://filcorgourmet.com/shopping_cart.php" class="headerNavigation">Cart Contents</a>  |  <a href="http://filcorgourmet.com/checkout_shipping.php" class="headerNavigation">Checkout</a>   </td>
 </tr>
</table>
<!-- header_eof //-->

<!-- body //-->
[b]<table border="0" width="760" cellspacing="0" cellpadding="3">[/b]
 <tr>
   <td width="155" valign="top"><table border="0" width="155" cellspacing="0" cellpadding="0">
<!-- left_navigation //-->
<!-- categories //--> 

jon

It's all just ones and zeros....

Link to comment
Share on other sites

Sometimes it helps to view the source code of a page that works (example: crespi) and a page that doesn't (index.php). In your index.php, there is a table width specified at 760. In your crespi page, that same table is specified at 100%, the cellspacing & padding are 3. I think if you change your index.php 760 table width to 100% and cellspacing & padding to 3, your problem may be resolved.

 

You may very well be using a template. Look for that 760 there. If not, open index.php in a text editor and look for this:

 

<table border="0" width="100%" height="25" cellspacing="0" cellpadding="0">
 <tr class="headerNavigation">
   <td class="headerNavigation">  <a href="http://filcorgourmet.com/index.php" class="headerNavigation">Home</a></td>
   <td align="right" class="headerNavigation"><a href="http://filcorgourmet.com/account.php" class="headerNavigation">My Account</a>  |  <a href="http://filcorgourmet.com/shopping_cart.php" class="headerNavigation">Cart Contents</a>  |  <a href="http://filcorgourmet.com/checkout_shipping.php" class="headerNavigation">Checkout</a>   </td>
 </tr>
</table>
<!-- header_eof //-->

<!-- body //-->
[b]<table border="0" width="760" cellspacing="0" cellpadding="3">[/b]
 <tr>
   <td width="155" valign="top"><table border="0" width="155" cellspacing="0" cellpadding="0">
<!-- left_navigation //-->
<!-- categories //--> 

jon

Jon: Worked! thanks alot!! (never thought such a little thing could make me so happy)

appreciate your looking into this.

mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...