Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Add to cart not working


dean0088

Recommended Posts

Everything seems to function properly, however when I click add to cart it goes to the shopping cart page, but it says your cart is empty.

 

I do not get any error messages.

 

Any ideas?

 

Dean

goto your osc admin->configuration->sessions make sure the force cookie use is set to false. Then go to the catalog click a link to go to a product check if the address bar of your browser includes the osCsid parameter. Make a note of its value. Add a product to the cart and check if the osCsid remains the same. This could be a problem with the sessions (which may point to your includes/configure.php) or if you're using hard-coded links that may also cause it.

 

You can post a link to a product if this store is online so we can see what's going on.

Link to comment
Share on other sites

probably session is getting lost.

Check on session id.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

goto your osc admin->configuration->sessions make sure the force cookie use is set to false. Then go to the catalog click a link to go to a product check if the address bar of your browser includes the osCsid parameter. Make a note of its value. Add a product to the cart and check if the osCsid remains the same. This could be a problem with the sessions (which may point to your includes/configure.php) or if you're using hard-coded links that may also cause it.

 

You can post a link to a product if this store is online so we can see what's going on.

 

Thanks for your help, I tried what you suggested and do not see and changes.

 

Here is the link

 

www.cartridgetogo.com

 

Dean

Link to comment
Share on other sites

Thanks for your help, I tried what you suggested and do not see and changes.

 

Here is the link

 

www.cartridgetogo.com

 

Dean

yea, ok now, go to your includes\configure.php change the code

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

to this:

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

Link to comment
Share on other sites

and goto your osc admin->configuration->sessions->session directory and specify a valid directory outside your www domain like

/home/my_root/tmp

this is an example the path must be valid

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...