Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Authorize.net - TIMEOUT


youngerassociates

Recommended Posts

Hi All - I'm having trouble getting Authorize.net to redirect me to my final page. I'm currently using the latest version of OSC with the normal authorize module 1.48.

 

Each time I proceed to the checkout, I get the error that the card was approved, but there was an error. The transactions show up in authorize, but I don't get redirected -- so there's no orders in the OSC database.

 

I've read several threads and have tried for quite a while. I've double checked the login info for authorize (shouldn't be an issue b/c it is showing up there).

 

Any help would be GREATLY appreciated.

 

-- Dan

Link to comment
Share on other sites

And your server has curl? Have your ever had your module work?

 

 

Hi All - I'm having trouble getting Authorize.net to redirect me to my final page. I'm currently using the latest version of OSC with the normal authorize module 1.48.

 

Each time I proceed to the checkout, I get the error that the card was approved, but there was an error. The transactions show up in authorize, but I don't get redirected -- so there's no orders in the OSC database.

 

I've read several threads and have tried for quite a while. I've double checked the login info for authorize (shouldn't be an issue b/c it is showing up there).

 

Any help would be GREATLY appreciated.

 

-- Dan

Link to comment
Share on other sites

Not sure who your host is - but I had precisely this problem with Network Solutions. The site was generally very slow and after reading about a lot of performance problems related to their MySQL server I switched hosts. The A.net timeout problem magically disappeared after that.

Link to comment
Share on other sites

Jason - Thanks for the reply! Unfortunately I don't think it is a hosting issue. We have very fast hosting -- only a few sites on our server =). Anyway, authroize sends the error almost immediately. I'm thinking it may have something to do with an error in their reply... ???

Link to comment
Share on other sites

Authorize.net needs libcurl on your server. Do you have that enabled?

 

 

 

Jason - Thanks for the reply! Unfortunately I don't think it is a hosting issue. We have very fast hosting -- only a few sites on our server =). Anyway, authroize sends the error almost immediately. I'm thinking it may have something to do with an error in their reply... ???
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...