Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cannot Install Help


DonJuan

Recommended Posts

I've installed Apache 2.2, My Sql 5.01, the SQL server is running and i created also a DB. I copied all the fils of os-commerce under the localhost apache server directory ( htdocs ). PHP 5.2.1 is running too. So i launch the install wizard with netscape 8.1.2 http://localhost/osc/catalog/install/index.php ( osc is the name i gived to the oscommerce directory, just changed ).

 

So the wizard starts, click to the left button to install a new online store.

Step 2 i check the boxes for the 1st installation etc. ,

Press continue and away to go to step 3, it reload always the step 2 page.

 

Any idea or suggestion ?

Thanks

 

DonJuan

Link to comment
Share on other sites

So the wizard starts, click to the left button to install a new online store.

Step 2 i check the boxes for the 1st installation etc. ,

Press continue and away to go to step 3, it reload always the step 2 page.

 

If you read the first introduction page it says that osC will run under php 3 or 4.

 

If you are just trying to load Apache as a test and debug service for use on your own pc, I would suggest trying XAMPP. I use it on mine version 1.5.4a and it works great.

AND its free!

Lloyd

Link to comment
Share on other sites

If you read the first introduction page it says that osC will run under php 3 or 4.

 

If you are just trying to load Apache as a test and debug service for use on your own pc, I would suggest trying XAMPP. I use it on mine version 1.5.4a and it works great.

AND its free!

I dont thinks this is the problem 'cause the PHP requirement is "from 4.0 to the latest version" or 4.0+ if you like.

 

I use Apache on my machine for development yes. Its free too and is the best e most used web server around the globe ! ;)

Anyway thanks for the hint. I'll try it but i dont think the problem is with the Apache itself ( maybe some configuration issue, but i dont know what ).

 

Bye

Link to comment
Share on other sites

I dont thinks this is the problem 'cause the PHP requirement is "from 4.0 to the latest version" or 4.0+ if you like.

 

I use Apache on my machine for development yes. Its free too and is the best e most used web server around the globe ! ;)

Anyway thanks for the hint. I'll try it but i dont think the problem is with the Apache itself ( maybe some configuration issue, but i dont know what ).

 

Bye

 

Have a look at your php.ini file make sure the following is set

 

register_long_arrays = On

 

worked for me :rolleyes:

php5.2.0

mysql 5.0.26

apache2

SuSE10.2

 

and don't forget to restart the webserver after changing your php.ini file

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...