Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

INSTALLATION PHP.INI


WANDAFULGIFTS

Recommended Posts

I am new and trying to learn how to set up oscommerce...I get error FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I am working on locol host and going to folder /catalog/installand get FATAL ERROR: register_globals is disabled in php.ini, please enable it! when I double click on install php...and I do not see any thing like install button just listing of filed in folder

I also tried to set up new data base,and not it wants name and amount of tables and I am lost

Link to comment
Share on other sites

when local host (your PC) you will need to navigate to your server software

my computer->c drive->program files->etc...

in the files for the server software there will be a file (sometimes more than one) called php.ini

open it up and change register globals to on

You may need to restart the server to take affect,

My Contributions

 

Stylesheet With Descriptions Glassy Grey Boxtops Our Products Meta Tags On The Fly

Password Protect Admin

"No matter where you go....There you are" - Buccaroo Bonsai

Link to comment
Share on other sites

I am new and trying to learn how to set up oscommerce...I get error FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

I am working on locol host and going to folder /catalog/installand get FATAL ERROR: register_globals is disabled in php.ini, please enable it! when I double click on install php...and I do not see any thing like install button just listing of filed in folder

I also tried to set up new data base,and not it wants name and amount of tables and I am lost

 

 

I experienced this same problem... do this...

 

create a php.ini file with any plain text editor. The contents of that file should be:

 

register_globals = on;

 

Place a copy of the php.ini file in each directory.

Link to comment
Share on other sites

when local host (your PC) you will need to navigate to your server software

my computer->c drive->program files->etc...

in the files for the server software there will be a file (sometimes more than one) called php.ini

open it up and change register globals to on

You may need to restart the server to take affect,

I have done that and also tried making a new php.ini file like the other member reccomended and still get

I am using mini portal and went to c:programs.instantserver.miniportal.apachie and changed the php.ini

I get error FATAL ERROR: register_globals is disabled in php.ini, please enable it! and even tried to replace it with

a php.ini that was from another folder that had register_globals on

I did a search for php.ini file and I have a bunch of them in different places

thanks :'(

Link to comment
Share on other sites

In your catalog folder and admin folder there is a file ( .htaccess ) open it in a notepade and uncommint the system global like and save the fole then refresh ur page .....i think u solve ur it ... cheers

 

 

I found folder and filemwhat do you mean uncommint the system global?

 

# $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

 

 

 

 

thanks

Link to comment
Share on other sites

I found folder and filemwhat do you mean uncommint the system global?

 

# $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

#

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

#

<IfModule mod_php4.c>

php_value session.use_trans_sid 0

php_value register_globals 1

</IfModule>

thanks

Make it look like above (last 4 lines)

My Contributions

 

Stylesheet With Descriptions Glassy Grey Boxtops Our Products Meta Tags On The Fly

Password Protect Admin

"No matter where you go....There you are" - Buccaroo Bonsai

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...