Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

STS won't appear in Admin->Modules section when files uploaded


platinumidesigns

Recommended Posts

On two different Hosting providers (arachnonet.com) and (siteground.com), after uploading some of the recent versions of the STS 4.x I went to the admin area and do not see the STS module under the Modules section. Ironically, I did a quick install of OsCommerce on my laptop using WAMP5 (WinXP) and not only did the OsCommerce install go flawlessly, but STS installed worked like like a champ.

 

I have read experiences someplaces where other users have seen the STS there but couldn't set it to true do to the $ar value - refresh bug. I haven't even gotten it to display.

 

Has anyone here had that experience. If so, what is the solution. I tried several times by removing the installations and re-installing and trying to ftp the files from the STS pack as I did locally. After the ftp uploads, there were no errors and the catalog still loads fine but the STS module does not appear. I tried refreshing, clearing the session, etc..Nothing has seemed to work.

Link to comment
Share on other sites

Actually..depending on which version were talking about ...v4.4 does have the new_files and modified_files subfolders...but v4.5 i think has just a catalog folder with an admin and includes subfolder. For v4.5 I just uploaded the and overwrote what was there in the catalog folder of a clean OScommerce MS2.2 install. When i tried v4.4, i used the new_files.

 

1) Make a backup of your application.

2) Do it again

3) Copy all the new files to your store: copy the files from the folder "new_files/catalog" over your catalog.

4) Some osCommerce files need to be modified. If you have a clean osCommerce install, you can just copy the files located in the "modified_files/catalog" folder over your catalog. If you have already installed other contributions, you can use a comparison program or make the changes manually.

 

 

However, this did not make STS show up in the admin->modules area.

Link to comment
Share on other sites

For STSv4.4, you need both the new files as well as the modified files. They are separated so that you can easily upload all of the new files without any worries of overwriting any existing code. The modified files represent existing files in your store that need to be "modified" in order to complete the installation.

 

For STSv4.5, all of the files have been compiled into the catalog folder. However, the installation instructions are still the same as all the "new" files are listed so that you can easily just copy over these files, but you still need to make the other modifications to all of the existing files in your store in order to complete the installation.

 

Hope this helps, (if not, please follow the link below to the official STSv4.x forum where you will get a faster response to your question as well as get more input from other STS users)

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Link to comment
Share on other sites

Okay,

 

I am still having trouble getting the STS 4.4 to show as an active link under the Admin->Modules area. After reading the STS4.4 Installation and following all the steps for an OsCommerce MS 2.2 Clean Install, I was unable to get the STS to become visible. I uploaded all the files (ftp) to the 2 different web hosting accounts...I opened and looked through each of the modified_files to verify the changes were manually made. They're already modified to what they say they should be. No changes need to be made...everything outlined under the Admin side and Catalog side is currently present and accounted for. This is weird. After numerous attempts...the STS never shows up in the admin->modules. What could be wrong. There are no error messages with OScommerce..its as if nothing was done.

 

Note: I got this working on my local laptop PC (using WAMP5).

 

I tried posting to the STS Forum...the system logged me out then rentered password it took me in then I ended up posting to the templates forum.

 

Which one of those links is the official one?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...