Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

host issued ssl with https://www.domain.com


savage68

Recommended Posts

i have a problem and i was wondering how i could fix this. I got my ssl certificate installed by my hosting service and they said that the SSL certificate https://www.mydomain.com and not just https://mydomain.com.

 

i have no way of getting them to change this and i was wondering why i keep getting errors on every secure page such as my account ect...

 

is there any way to change the config to adapt to this change in the SSL installed name to keep the links from going to https://mydomain.com/myaccount.php ect and marking the pages as insecure??

Link to comment
Share on other sites

ok the site is www.oboxers.com

 

 

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://www.oboxers.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://www.oboxers.com'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'oboxers.com');
 define('HTTPS_COOKIE_DOMAIN', 'oboxers.com');
 define('HTTP_COOKIE_PATH', '/catalog/');
 define('HTTPS_COOKIE_PATH', '/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/oboxersc/public_html/catalog/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', ********);
 define('DB_SERVER_PASSWORD', *****');
 define('DB_DATABASE', **********);
 define('USE_PCONNECT', 'true'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

even when i click to continue to the site anyways despite the certificate error you get on the first page it keeps saying i have insecure items on the page.

Link to comment
Share on other sites

the problem is with the flash header.

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="766" height="190" title="header">
	  <param name="movie" value="banner2.swf" />
	  <param name="quality" value="high" />
	  <embed src="banner2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="766" height="190"></embed>
	  </object>

 

i am trying to remember how to fix this exactly, but this is the unsecure item that is appearing on the page. Where it is pulling the codebase from is just a http:// and it should be https://

Link to comment
Share on other sites

the problem is with the flash header.

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="766" height="190" title="header">
	  <param name="movie" value="banner2.swf" />
	  <param name="quality" value="high" />
	  <embed src="banner2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="766" height="190"></embed>
	  </object>

 

i am trying to remember how to fix this exactly, but this is the unsecure item that is appearing on the page. Where it is pulling the codebase from is just a http:// and it should be https://

 

hey just wanted to say thanks for helping me with this

Link to comment
Share on other sites

no problem.

 

try this, in that section of code for your flash header replace it with this:

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="766" height="190" title="header">
	  <param name="movie" value="https://www.oboxers.com/catalog/banner2.swf" />
	  <param name="quality" value="high" />
	  <embed src="banner2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="766" height="190"></embed>
	  </object>

 

 

Upload that to your store and see if the errors still appear when going to the account pages.

Link to comment
Share on other sites

no problem.

 

try this, in that section of code for your flash header replace it with this:

 

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="766" height="190" title="header">
	  <param name="movie" value="https://www.oboxers.com/catalog/banner2.swf" />
	  <param name="quality" value="high" />
	  <embed src="banner2.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="766" height="190"></embed>
	  </object>

Upload that to your store and see if the errors still appear when going to the account pages.

i'll try that now

Link to comment
Share on other sites

Well, that idea didn't work :) You'll have to bear with me it has been a long day/week.

 

On another note, I did find another problem in the code:

 

<li><a href=http://www.oboxers.com/catalog/index.php?cPath=22>Boxer Briefs</a></li><li><a href=http://www.oboxers.com/catalog/index.php?cPath=21>Boxers</a></li>

 

Should be:

 

<li><a href="http://www.oboxers.com/catalog/index.php?cPath=22">Boxer Briefs</a></li><li><a href="http://www.oboxers.com/catalog/index.php?cPath=21">Boxers</a></li>

 

I'll keep digging for you.

Link to comment
Share on other sites

Well, that idea didn't work :) You'll have to bear with me it has been a long day/week.

 

On another note, I did find another problem in the code:

 

<li><a href=http://www.oboxers.com/catalog/index.php?cPath=22>Boxer Briefs</a></li><li><a href=http://www.oboxers.com/catalog/index.php?cPath=21>Boxers</a></li>

 

Should be:

 

<li><a href="http://www.oboxers.com/catalog/index.php?cPath=22">Boxer Briefs</a></li><li><a href="http://www.oboxers.com/catalog/index.php?cPath=21">Boxers</a></li>

 

I'll keep digging for you.

i couldn't find that code anywhere in the site. but i am still getting insecure items warnings all throughout the site.

Link to comment
Share on other sites

One problem is still in the flash header

Change

codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"

To

codebase="https://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"

And

pluginspage="http://www.macromedia.com/go/getflashplayer"

To

pluginspage="https://www.macromedia.com/go/getflashplayer"

Link to comment
Share on other sites

One problem is still in the flash header

Change

codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"

To

codebase="https://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"

And

pluginspage="http://www.macromedia.com/go/getflashplayer"

To

pluginspage="https://www.macromedia.com/go/getflashplayer"

FANTASTIC!

 

i think that does it for me guys, all my pages are good now!!!

 

awesome helpful forums, i love it

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...