Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Newbie - Please Help


DataMouse

Recommended Posts

Hi folks

 

I've done my installation and got it up and running at www.DataMouse.biz/catalog

I've changed the default image files to customise the look (a cheat, I know).

 

However, I have a couple of issues. All of my products will be for download (no "physical" items).

 

I've added the files to the downloads folder, added the descriptions (for some products) and set up the download options as per the instal guide.

However, I get sent to a "shipping address" screen and I get this error when I try to checkout:

 

 

Warning: Division by zero in /homepages/1/d163279975/htdocs/catalog/includes/classes/shipping.php on line 61

Warning: Division by zero in /homepages/1/d163279975/htdocs/catalog/includes/classes/shipping.php on line 62

Warning: Cannot modify header information - headers already sent by (output started at /homepages/1/d163279975/htdocs/catalog/includes/classes/shipping.php:61) in /homepages/1/d163279975/htdocs/catalog/includes/functions/general.php on line 33

 

I have absolutely no idea what this means.

 

As a seperate issue, I'd really like to add a flash header to the OSC part (same as the rest of my site).

The banner would be 780 x 170.

 

How do I add this instead of the header image (on the left) and the "my account"/"cart contents"/"checkout" icons (on the right)?

 

Thanks for any help you can offer.

 

Danny

Link to comment
Share on other sites

As your site provides download products be no shipping cost.

probably You have added or made some configuration mistake leading it the cart items being assumed not to be virtual.

check you havent specified wait plus set download to true.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

As your site provides download products be no shipping cost.

probably You have added or made some configuration mistake leading it the cart items being assumed not to be virtual.

check you havent specified wait plus set download to true.

 

Satish

 

Hi Satish

Apologies for the delay in response.

 

When you say a "mistake", do you mean that the setup is correct, but the items that I've added have an error?

 

How do I tell?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...