Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Completely Stuck (new to this) oscommerce will not install


Recommended Posts

Database Import


(This is the error that endlessly repeats when the database import is started)


Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/alexclif/public_html/fabooks/catalog/install/includes/functions/database.php on line 41


I have no idea what this means, or why when the whole page is chock full of this error message, oscommerce install reports:


"The database import was successful!"



I then continue. presented with the following:



osCommerce Configuration


Please enter the web server information:




Webserver Root Directory:


The server path to the online store

The directory where osCommerce is installed on the server,

for example /home/myname/public_html/osCommerce/




The domain to store cookies in

The full or top-level domain to store the cookies in, for example .my-server.com


HTTP Cookie Path: /fabooks/catalog/


The path to store cookies under

The web address to limit the cookie to, for example /catalog/

Enable SSL Connections


-----------------------------------------------SSL connection left off(wouldnt install)


Database Server: www.fastandbulbous.org.uk


Hostame or IP-address of the database server

The database server can be in the form of a hostname,

such as db1.myserver.com, or as an IP-address, such as


Username: PROVIDED


Database username

The username used to connect to the database server.

An example username is 'mysql_10'.


Note: Create and Drop permissions

are not required for the general use of osCommerce.


Password: PROVIDED

Database password

The password is used together with the username,

which forms the database user account.


Database Name: PROVIDED



Persistent Connections:


Enable persistent database connections. (Not enabled)


Note: Persistent connections should be

disabled for shared servers.


(I'm not sure what is meant by "Shared servers" I have several sites operating from the same hosting account, is that "Shared"?)



Session Storage: Database


Store user session data as files on the server,

or in the database.


Note: Due to security related issues,

database session storage is recommended for shared servers."








"osCommerce Configuration


A test connection made to the database was NOT successful.


The error message returned is:


Table 'alexclif_fastandbulbousmysql.configuration' doesn't exist


Please click on the Back button below to review your database server settings.


If you require help with your database server settings, please consult your hosting company."






"osCommerce Configuration


The following error has occurred:



The configuration files do not exist, or permission levels are not set.


Please perform the following actions:

cd /home/alexclif/public_html/fabooks/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/alexclif/public_html/fabooks/catalog/admin/includes/

touch configure.php

chmod 706 configure.php


If chmod 706 does not work, please try chmod 777.


If you are running this installation procedure under a Microsoft Windows environment, try renaming the existing configuration file so a new file can be created."


I'm just going round in circles.


My host support (James who owns the host and is very knowledgable responded thus)


"Hi Alex,


Yes you are inputting all the right settings and data because I did

the samething as you and getting the same error as you.


I even CHMOD the configure.php to "777" but still getting the same error?


You need to contact OsCommerce support


about this issue here:









And thats how I ended up HERE!

I hope someone here can solve the riddle cause I'm stumped, being new to all this.

I don't even know what CHMOD is, and it's no good telling me to read the manual because I can't follow technical details that way, I only seem to learn by doing.


Anyone got any Ideas please?


Maybe a PREVIOUS version rather than the new one would work better?


Thanks for taking the time to read this. Sorry it's so long.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...