Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help - Admin works but my online catalog shows blank page


Guest

Recommended Posts

Hi everyone. This regards the 'Admin works but my online catalog shows blank page' issue.

 

All was installed and fine. Today I was doing an update and instead of uploading selected files I uploaded my entire local osCommerce Catalog folder. I saw no harm in this as all previous edits on my local working copy should be identical to what's been previously uploaded.

When I went to view the online catalog, got the blank page.

 

Unfortunately I still had the 'Install' folder inside my local one.

All of the files are on the server, I can't figure out what's happened, though I did catch my mistake of re-uploading the 'install' folder and have deleted that. I also ran up my latest backup and still get the blank page.

 

Does anyone know why a re-upload of the local catalog(including the 'install' folder by oversight) causes index.php to fail to show it's html page? I sure won't do it again but I need to know what this screws up. What I uploaded is my local work copy so I assumed it should not change any code.

 

Note: STS v4.4 is installed, and in Admin is still default to use my custom template, which had all worked fine.

I can't find a problem which is causing the index.php to fail to show anything. Nothing in my Admin has changed -- but index.php doesn't invoke it's html page now

 

 

Things I've tried---

-I deleted the re-upload of 'install', and checked the files for correct CHMOD settings, and they are as they should be.

 

- includes/configure.php is on the server. I don't think I'm supposed to delete it. I renamed it 'OLD' but that didn't fix it so I've renamed it back to configure.php

 

-checked my database table on the server and nothing seems to have changed there either.

 

Anybody solved this issue? I figure people have done the same -- once! (I'll sure know better next time...)

Link to comment
Share on other sites

Hi,

 

I don't know if this is going to help, but did you check your config.php file in the includes directory? Maybe you have to add the root in the code. There is a good post about the config.php file: http://www.oscommerce.com/forums/index.php?showtopic=193738.

 

Maybe that will fix your problem.

 

Karin

Link to comment
Share on other sites

Turned out everything was unchanged. CHMOD permissions, and the root directory.

 

I went ahead and uninstalled/reinstalled osCommerce. I'd saved my sts-template and the images for it, so it wasn't much time to replace it in the clean install, once I'd re-installed STS, and fixed the 'refresh bug'.

 

Never did figure out how uploading the catalog folder broke it, but you can bet I won't make that mistake again!

 

Thanks for the help. I have the store back up.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...