Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Will someone please help me ?


Recommended Posts

I keep getting the following message, when I click on "my account" and "checkout" links on any page of my catalog :cry: . The message reads :


"Warning: Cannot add header information - headers already sent by (output started at /home/giftsbyn/public_html/shop/includes/languages/english.php:295) in /home/giftsbyn/public_html/shop/includes/functions/general.php on line 25"


If anyone can please help me correct this problem, it would be greatly appreciated.

Gralyn Edwards

Gifts by Nicole



The Perfect Gift At The Perfect Price !

Link to comment
Share on other sites

I tried this from the FAQ article but I'm still getting same problem. What is going on here? I have exchange 5.5 server ESMTP on the same machine and running IIS 5.0. Users are able to create their account with the domains hosted by my Exchange server, but fails to register new account with any outside email addresses such hotmail.com. Please help!!!!



Warning: Server Error in C:Inetpubwwwrootkevin2koolcatalogincludesclassesemail.php on line 500


Warning: Cannot add header information - headers already sent by (output started at C:Inetpubwwwrootkevin2koolcatalogincludesclassesemail.php:500) in C:Inetpubwwwrootkevin2koolcatalogincludesfunctionsgeneral.php on line 23

Link to comment
Share on other sites

I dont know if this helps but here goes. My site is not yet live so it was easy for me to uninstall and then reinstall os commerce. Not sure you would want to do that or not, but I found that as I edited the Includes/Languages/english.php file, my online editor was adding whitespace somewhere. I never could find out where, but I had copied everything inthe English.php file into a notepad on my desktop. Later after reconfiging some of the site, I realized it had happend again...the online editor added more whitespace and I got the same error. I jsut copied the english.php code from my desktop back into the online english.php file...replacing all of it, and viola !All was fixed. I still cant figure out where the whitespacee was being added, but having a copy of that file for backup is the easiest way I could think to fix it. Hope this helps, and let me know if there is an easier way or you find where the whitespace is added.



Atomic 47

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...