Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Installation Help - Newbie


Recommended Posts

Howdy yall; :)


I?m a complete newbie when it comes to PHP/MySQL, but I needed a PHP/MySQL shopping cart solution.


As of now I have ?PHPMyAdmin? installed and I?m really still unsure how I managed to get that working right. For temp, the server is on my IP which is behind a Linksys router, which the web server and all ports are being forwarded too.


Server Specs:

Win2k Server

Apache 1.3.27

PHP V4.2.3 ? C:/PHP -

MySQL v4.0.4-b ? C:/mysql

ActivePerl v5.6.1 ? C:/perl


Dir Structure:

Document Root = D:/www/htdocs


catalog = D:/www/htdocs/catalog

admin = D:/www/htdocs/catalog/admin




Right now I?m at the point where I should create a catalog in MySQL, and then do something with ?mysql_catalog.sql? Well I have NO idea what to do. I have tried the following, and nothing is added, or created. I was thinking maybe I can do this thru PHPMyAdmin, but I could not figure it out. :cry:


mysqladmin create catalog

mysql catalog < ./mysql_catalog.sql


I have searched thru the forums, and tried to figure this out as much as I can, but I?m at the point where I?m just so frustrated that I can?t function to even figure what?s the matter.


If you need snippets of anything please let me know. . Everything is temp as far as usernames/passwords and IP. So I?m not really worried about sharing info with you all, Just as long as I can get OSCommerce to work on my server.


Thank you for your help, suggestions and advice!

Link to comment
Share on other sites

penfold = gawd! :D


Basically.... was using 2.1, he switched me to 2.2 and the install was such a breeze!


Had a few issues, but got it all worked out!!!


BIG Thanx goes to penfold!!!!


Link to comment
Share on other sites

New as well however the command displayed is correct, but you might need to utilize the user and password flags.



mysql -u root -p catalog < thesqlfile.sql


When mysql defaults install the default username needs to be used and a blank paswword

Link to comment
Share on other sites



Store has been working for a few days now :)


As you can see in my post right above yours, I said that penfold helped me get it working...



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...