Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

"Tax" doesn't show out


Recommended Posts

Hello, I am new to OsCommerce. I just spent amount of time finishing installation and setting up. However, while I was testing, I found in Order Confirm page, it shows the tax amount but didn't show the word "Tax", so it looks like:

Sub-Total: $111.99

Flat Rate (Best Way): $5.00

: $8.68

Total: $125.67


Customer may confuse on what amount is that. Did I missed to turn on some setting or what should I do to make the word "Tax" show out?


Thank you....

Link to comment
Share on other sites

the tax string is pulled from the catalog\includes\languages\english\modules\orders_total\ot_tax.php. So if the strings in that file are ok it should show up. Assuming you havent touched the ot_tax files and your tax module is installed in the order total in osc admin->modules

Link to comment
Share on other sites

Thanks for the reply. I don't remember I have ever touched the anything of the file. So I went to the file "catalog\includes\languages\english\modules\orders_total\ot_tax.php", and here is the code, I am not sure if they are supposed to be like this:



$Id: ot_tax.php,v 1.1 2002/04/03 23:09:49 hpdl Exp $


osCommerce, Open Source E-Commerce Solutions



Copyright © 2002 osCommerce


Released under the GNU General Public License







And the setting in "Order Total Modules" is like this:

Order Tax


Display Tax



Sort Order



Is anything wrong with my setting or my file? how come the word "Tax" just not show out?

Link to comment
Share on other sites

I believe it's the "Tax description" that you're looking for.


Admin->Locations/Taxes->Tax Rates->each tax rate has to have something entered under the "Description" field

Do, or do not. There is no try.


Order Editor 5.0.6 "Ultra Violet" is now available!

For support or to post comments, suggestions, etc, please visit the Order Editor support thread.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...